summaryrefslogtreecommitdiff
path: root/net-libs/pacparser/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-libs/pacparser/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-libs/pacparser/files')
-rw-r--r--net-libs/pacparser/files/pacparser-1.4.0-build.patch96
-rw-r--r--net-libs/pacparser/files/pacparser-1.4.0-pymod.patch61
2 files changed, 157 insertions, 0 deletions
diff --git a/net-libs/pacparser/files/pacparser-1.4.0-build.patch b/net-libs/pacparser/files/pacparser-1.4.0-build.patch
new file mode 100644
index 000000000000..2a8898579327
--- /dev/null
+++ b/net-libs/pacparser/files/pacparser-1.4.0-build.patch
@@ -0,0 +1,96 @@
+Upstream-PR: https://github.com/manugarg/pacparser/pull/136
+From 5d689be2e250242ef4022054f11bf00af339c149 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 13 May 2022 22:34:37 -0700
+Subject: [PATCH 1/2] build: Don't conflict with the user's CFLAGS
+
+This uses the variable MAINT_CFLAGS to set the project's flags so that
+the user can set CFLAGS as an environment variable or as an make
+argument without any conflicts.
+
+This can be problemtic with the build environment in some distros.
+---
+ src/Makefile | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 87f5c1b..3642241 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -60,14 +60,14 @@ ifeq ($(OS_ARCH),Darwin)
+ endif
+
+ PREFIX ?= /usr
+-CFLAGS = -g -DXP_UNIX -Wall -DVERSION=$(VERSION)
++MAINT_CFLAGS := -g -DXP_UNIX -Wall -DVERSION=$(VERSION)
+
+ ifndef PYTHON
+ PYTHON = python
+ endif
+
+ # Spidermonkey library.
+-CFLAGS += -Ispidermonkey/js/src
++MAINT_CFLAGS += -Ispidermonkey/js/src
+
+ LIBRARY_LINK = $(LIBRARY_NAME).$(SO_SUFFIX)
+ PREFIX := $(DESTDIR)$(PREFIX)
+@@ -87,17 +87,17 @@ spidermonkey/libjs.a: spidermonkey/js/src
+ cd spidermonkey && SMCFLAGS="$(SHFLAGS) $(SMCFLAGS)" $(MAKE) jslib
+
+ pacparser.o: pacparser.c pac_utils.h pacparser.h jsapi_buildstamp
+- $(CC) $(CFLAGS) $(SHFLAGS) -c pacparser.c -o pacparser.o
++ $(CC) $(MAINT_CFLAGS) $(CFLAGS) $(SHFLAGS) -c pacparser.c -o pacparser.o
+ touch pymod/pacparser_o_buildstamp
+
+ $(LIBRARY): pacparser.o spidermonkey/libjs.a
+- $(MKSHLIB) $(CFLAGS) $(LDFLAGS) $(LIB_OPTS) -o $(LIBRARY) pacparser.o spidermonkey/libjs.a -lm
++ $(MKSHLIB) $(MAINT_CFLAGS) $(CFLAGS) $(LDFLAGS) $(LIB_OPTS) -o $(LIBRARY) pacparser.o spidermonkey/libjs.a -lm
+
+ $(LIBRARY_LINK): $(LIBRARY)
+ ln -sf $(LIBRARY) $(LIBRARY_LINK)
+
+ pactester: pactester.c pacparser.h pacparser.o spidermonkey/libjs.a
+- $(CC) $(CFLAGS) $(LDFLAGS) pactester.c pacparser.o spidermonkey/libjs.a -o pactester -lm -L. -I.
++ $(CC) $(MAINT_CFLAGS) $(CFLAGS) $(LDFLAGS) pactester.c pacparser.o spidermonkey/libjs.a -o pactester -lm -L. -I.
+
+ testpactester: pactester $(LIBRARY_LINK)
+ echo "Running tests for pactester."
+
+From ff86f230de5dd60935e1793077eb038fcbe1e515 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 13 May 2022 22:45:19 -0700
+Subject: [PATCH 2/2] build: Add DOC_PREFIX
+
+This can be useful for distro integration.
+---
+ src/Makefile | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 3642241..af10890 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -74,6 +74,7 @@ PREFIX := $(DESTDIR)$(PREFIX)
+ LIB_PREFIX = $(PREFIX)/lib
+ INC_PREFIX = $(PREFIX)/include
+ BIN_PREFIX = $(PREFIX)/bin
++DOC_PREFIX = $(PREFIX)/share/doc/pacparser
+ MAN_PREFIX = $(PREFIX)/share/man
+
+ .PHONY: clean pymod install-pymod
+@@ -119,11 +120,11 @@ install: all
+ install -d $(MAN_PREFIX)/man3/
+ (test -d ../docs && install -m 644 ../docs/man/man3/*.3 $(MAN_PREFIX)/man3/) || true
+ # install html docs
+- install -d $(PREFIX)/share/doc/pacparser/html/
+- (test -d ../docs/html && install -m 644 ../docs/html/* $(PREFIX)/share/doc/pacparser/html/) || true
++ install -d $(DOC_PREFIX)/html/
++ (test -d ../docs/html && install -m 644 ../docs/html/* $(DOC_PREFIX)/html/) || true
+ # install examples
+- install -d $(PREFIX)/share/doc/pacparser/examples/
+- (test -d ../examples && install -m 644 ../examples/* $(PREFIX)/share/doc//pacparser/examples/) || true
++ install -d $(DOC_PREFIX)/examples/
++ (test -d ../examples && install -m 644 ../examples/* $(DOC_PREFIX)/examples/) || true
+
+ # Targets to build python module
+ pymod: pacparser.o pacparser.h spidermonkey/libjs.a
diff --git a/net-libs/pacparser/files/pacparser-1.4.0-pymod.patch b/net-libs/pacparser/files/pacparser-1.4.0-pymod.patch
new file mode 100644
index 000000000000..203e34c838f1
--- /dev/null
+++ b/net-libs/pacparser/files/pacparser-1.4.0-pymod.patch
@@ -0,0 +1,61 @@
+Upstream-PR: https://github.com/manugarg/pacparser/pull/137
+From 351b8f837ebbdf6e6fa4978a70287899436890eb Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sat, 14 May 2022 01:46:25 -0700
+Subject: [PATCH] tests: Fix python path in runtests.py
+
+In Gentoo the runtests.py script fails when it fails to determine the
+pacparser path.
+
+This happens because 'py_ver' expands to '3.9' when the expected
+directory ends in '39'. This can be solved by replacing any periods in
+the string.
+
+python ../tests/runtests.py
+Traceback (most recent call last):
+ File "/tmp/pacparser/src/../tests/runtests.py", line 31, in runtests
+ pacparser_module_path = glob.glob(os.path.join(
+IndexError: list index out of range
+
+During handling of the above exception, another exception occurred:
+
+Traceback (most recent call last):
+ File "/tmp/pacparser/src/../tests/runtests.py", line 81, in <module>
+ main()
+ File "/tmp/pacparser/src/../tests/runtests.py", line 78, in main
+ runtests(pacfile, testdata, tests_dir)
+ File "/tmp/pacparser/src/../tests/runtests.py", line 34, in runtests
+ raise Exception('Tests failed. Could not determine pacparser path.')
+Exception: Tests failed. Could not determine pacparser path.
+---
+ tests/runtests.py | 16 +++++++++++++---
+ 1 file changed, 13 insertions(+), 3 deletions(-)
+
+diff --git a/tests/runtests.py b/tests/runtests.py
+index 9760300..a5377d1 100644
+--- a/tests/runtests.py
++++ b/tests/runtests.py
+@@ -26,10 +26,20 @@
+ import sys
+
+ def runtests(pacfile, testdata, tests_dir):
+- py_ver = '.'.join([str(x) for x in sys.version_info[0:2]])
++ ver = '.'.join([str(x) for x in sys.version_info[0:2]])
++ py_ver = [ver, ver.replace('.', '')]
+ try:
+- pacparser_module_path = glob.glob(os.path.join(
+- tests_dir, '..', 'src', 'pymod', 'build', 'lib*%s' % py_ver))[0]
++ module_path = glob.glob(os.path.join(
++ tests_dir, '..', 'src', 'pymod', 'build', 'lib*'))
++ module_found = False
++ for module in module_path:
++ for version in py_ver:
++ if module.endswith(version):
++ module_found = True
++ break
++ if module_found:
++ pacparser_module_path = module
++ break
+ except Exception:
+ raise Exception('Tests failed. Could not determine pacparser path.')
+ if 'DEBUG' in os.environ: print('Pacparser module path: %s' %