summaryrefslogtreecommitdiff
path: root/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/openpgm/openpgm-5.1.118-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/openpgm/openpgm-5.1.118-r1.ebuild')
-rw-r--r--net-libs/openpgm/openpgm-5.1.118-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/openpgm/openpgm-5.1.118-r1.ebuild b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
new file mode 100644
index 000000000000..9afff1551e09
--- /dev/null
+++ b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-any-r1
+
+MY_PV="${PV//./-}"
+
+DESCRIPTION="Open source implementation of the Pragmatic General Multicast specification"
+HOMEPAGE="https://github.com/steve-o/openpgm"
+SRC_URI="https://github.com/steve-o/${PN}/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 x86 ~x86-fbsd"
+IUSE="static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/${PN}-release-${MY_PV}/${PN}/pgm"
+
+src_install() {
+ DOCS=( "${S}"/../doc/. "${S}"/README )
+
+ autotools-utils_src_install
+}