summaryrefslogtreecommitdiff
path: root/net-libs/ntirpc/ntirpc-4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /net-libs/ntirpc/ntirpc-4.0-r1.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'net-libs/ntirpc/ntirpc-4.0-r1.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-4.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-4.0-r1.ebuild b/net-libs/ntirpc/ntirpc-4.0-r1.ebuild
new file mode 100644
index 000000000000..e7d899f9943f
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-4.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake_src_configure
+}