summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-libs/nodejs/nodejs-99999999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-libs/nodejs/nodejs-99999999.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild34
1 files changed, 10 insertions, 24 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index d9745115c19f..577230345a35 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
@@ -19,11 +19,11 @@ if [[ ${PV} == *9999 ]]; then
else
SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
SLOT="0/$(ver_cut 1)"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
S="${WORKDIR}/node-v${PV}"
fi
-IUSE="cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl system-icu +system-ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl systemtap test"
REQUIRED_USE="inspector? ( icu ssl )
npm? ( ssl )
system-icu? ( icu )
@@ -33,7 +33,7 @@ RESTRICT="!test? ( test )"
RDEPEND=">=app-arch/brotli-1.0.9:=
>=dev-libs/libuv-1.40.0:=
- >=net-dns/c-ares-1.17.0:=
+ >=net-dns/c-ares-1.17.2:=
>=net-libs/nghttp2-1.41.0:=
sys-libs/zlib
system-icu? ( >=dev-libs/icu-67:= )
@@ -46,24 +46,9 @@ BDEPEND="${PYTHON_DEPS}
pax-kernel? ( sys-apps/elfix )"
DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PN}-12.22.1-jinja_collections_abc.patch # still needed as of 2021-06-04
-)
-
pkg_pretend() {
(use x86 && ! use cpu_flags_x86_sse2) && \
die "Your CPU doesn't support the required SSE2 instruction."
-
- if [[ ${MERGE_TYPE} != "binary" ]]; then
- if use lto; then
- if tc-is-gcc; then
- if [[ $(gcc-major-version) -ge 11 ]]; then
- # Bug #787158
- die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
- fi
- fi
- fi
- fi
}
src_prepare() {
@@ -95,7 +80,7 @@ src_prepare() {
fi
# We need to disable mprotect on two files when it builds Bug 694100.
- use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-13.8.0-paxmarking.patch )
+ use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-18.3.0-paxmarking.patch )
# All this test does is check if the npm CLI produces warnings of any sort,
# failing if it does. Overkill, much? Especially given one possible warning
@@ -143,6 +128,7 @@ src_configure() {
amd64) myarch="x64";;
arm) myarch="arm";;
arm64) myarch="arm64";;
+ lp64*) myarch="riscv64";;
ppc64) myarch="ppc64";;
x32) myarch="x32";;
x86) myarch="ia32";;
@@ -217,10 +203,10 @@ src_install() {
}
src_test() {
- # parallel/test-fs-mkdir is known to fail with FEATURES=usersandbox
if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ rm -f "${S}"/test/parallel/test-fs-mkdir.js
+ ewarn "You are emerging ${PN} with 'usersandbox' enabled. Excluding tests known to fail in this mode." \
+ "For full test coverage, emerge =${CATEGORY}/${PF} with 'FEATURES=-usersandbox'."
fi
out/${BUILDTYPE}/cctest || die