summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-27 12:17:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-27 12:17:07 +0100
commitc8e8719ce75120aeba1784b5edbe919b2e5e3dc3 (patch)
tree7945df945695274ce144a17413a1560dd350a60c /net-libs/nodejs/nodejs-99999999.ebuild
parent4936e2350e0b4aae482b12c7ce02aaa3c7e64842 (diff)
gentoo auto-resync : 27:04:2023 - 12:17:07
Diffstat (limited to 'net-libs/nodejs/nodejs-99999999.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index ef61e71e60d6..9277dca7ff05 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -24,7 +24,7 @@ else
S="${WORKDIR}/node-v${PV}"
fi
-IUSE="cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl test"
REQUIRED_USE="inspector? ( icu ssl )
npm? ( ssl )
system-icu? ( icu )
@@ -43,7 +43,6 @@ RDEPEND=">=app-arch/brotli-1.0.9:=
BDEPEND="${PYTHON_DEPS}
sys-apps/coreutils
virtual/pkgconfig
- systemtap? ( dev-util/systemtap )
test? ( net-misc/curl )
pax-kernel? ( sys-apps/elfix )"
DEPEND="${RDEPEND}"
@@ -104,14 +103,7 @@ src_prepare() {
fi
# We need to disable mprotect on two files when it builds Bug 694100.
- use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-18.3.0-paxmarking.patch )
-
- # All this test does is check if the npm CLI produces warnings of any sort,
- # failing if it does. Overkill, much? Especially given one possible warning
- # is that there is a newer version of npm available upstream (yes, it does
- # use the network if available), thus making it a real possibility for this
- # test to begin failing one day even though it was fine before.
- rm -f test/parallel/test-release-npm.js
+ use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-18.16.0-paxmarking.patch )
default
}
@@ -172,7 +164,6 @@ src_configure() {
"${EPYTHON}" configure.py \
--prefix="${EPREFIX}"/usr \
--dest-cpu=${myarch} \
- $(use_with systemtap dtrace) \
"${myconf[@]}" || die
}
@@ -236,11 +227,16 @@ src_install() {
}
src_test() {
- if has usersandbox ${FEATURES}; then
- rm -f "${S}"/test/parallel/test-fs-mkdir.js
- ewarn "You are emerging ${PN} with 'usersandbox' enabled. Excluding tests known to fail in this mode." \
- "For full test coverage, emerge =${CATEGORY}/${PF} with 'FEATURES=-usersandbox'."
- fi
+ local drop_tests=(
+ test/parallel/test-dns-setserver-when-querying.js
+ test/parallel/test-fs-mkdir.js
+ test/parallel/test-fs-utimes-y2K38.js
+ test/parallel/test-release-npm.js
+ test/parallel/test-socket-write-after-fin-error.js
+ test/parallel/test-strace-openat-openssl.js
+ test/sequential/test-util-debug.js
+ )
+ rm "${drop_tests[@]}" || die "disabling tests failed"
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die