summaryrefslogtreecommitdiff
path: root/net-libs/ngtcp2/ngtcp2-0.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
commit6c0d1528e3598898fd1026a3da35ffede0a1f14a (patch)
treed5ab9d7f6d2b41d05fb156069ee81e9ed779f12b /net-libs/ngtcp2/ngtcp2-0.12.1.ebuild
parent29efd7db303b443e103311cc0e458ee5c134e8e5 (diff)
gentoo auto-resync : 06:01:2023 - 18:11:38
Diffstat (limited to 'net-libs/ngtcp2/ngtcp2-0.12.1.ebuild')
-rw-r--r--net-libs/ngtcp2/ngtcp2-0.12.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/ngtcp2/ngtcp2-0.12.1.ebuild b/net-libs/ngtcp2/ngtcp2-0.12.1.ebuild
new file mode 100644
index 000000000000..aa53d73cfc95
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-0.12.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa ~riscv"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+gnutls openssl +ssl test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
+ -DENABLE_BORINGSSL=OFF
+ -DENABLE_PICOTLS=OFF
+ -DENABLE_WOLFSSL=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}