summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
commit8dd17625671faf6a47abf31d4c96a1e20d764ba5 (patch)
tree6dd5062cd293d1c2fc5af1f89cd548c7b3a62f3c /net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
parentd4725f7e03f4d243d29d408f4b9de39459e00d4c (diff)
gentoo auto-resync : 20:02:2023 - 02:17:29
Diffstat (limited to 'net-libs/nghttp3/nghttp3-0_pre20190912.ebuild')
-rw-r--r--net-libs/nghttp3/nghttp3-0_pre20190912.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
deleted file mode 100644
index 13c321f3927c..000000000000
--- a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
- inherit git-r3
-else
- GIT_COMMIT="51379a041174ad953dc6ad437712f3b279f81919"
- SRC_URI="https://github.com/ngtcp2/nghttp3/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${GIT_COMMIT}"
- KEYWORDS="~amd64 ~hppa"
-fi
-
-DESCRIPTION="HTTP/3 library written in C"
-HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="test"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_LIB_ONLY=ON
- -DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}