summaryrefslogtreecommitdiff
path: root/net-libs/nghttp2/nghttp2-1.51.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-30 11:00:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-30 11:00:41 +0000
commit18a69c52453e0db481bfa441cf1d9616c97c9928 (patch)
tree9ea41629c5312d98d2ac8bda976eb877403cd2f7 /net-libs/nghttp2/nghttp2-1.51.0.ebuild
parente984f0bb49fed14c51c7c15ed8d7b8bd2cca4b1d (diff)
gentoo auto-resync : 30:11:2023 - 11:00:41
Diffstat (limited to 'net-libs/nghttp2/nghttp2-1.51.0.ebuild')
-rw-r--r--net-libs/nghttp2/nghttp2-1.51.0.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/net-libs/nghttp2/nghttp2-1.51.0.ebuild b/net-libs/nghttp2/nghttp2-1.51.0.ebuild
deleted file mode 100644
index eaa187c5e227..000000000000
--- a/net-libs/nghttp2/nghttp2-1.51.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO: Add python support.
-
-EAPI=8
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="HTTP/2 C Library"
-HOMEPAGE="https://nghttp2.org/"
-SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz
- https://dev.gentoo.org/~voyageur/distfiles/${PN}-1.48.0-pthread.patch"
-
-LICENSE="MIT"
-SLOT="0/1.14" # <C++>.<C> SONAMEs
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="cxx debug hpack-tools jemalloc static-libs test utils xml"
-
-RESTRICT="!test? ( test )"
-
-SSL_DEPEND="
- >=dev-libs/openssl-1.0.2:0=[-bindist(-),${MULTILIB_USEDEP}]
-"
-RDEPEND="
- cxx? (
- ${SSL_DEPEND}
- dev-libs/boost:=[${MULTILIB_USEDEP}]
- )
- hpack-tools? ( >=dev-libs/jansson-2.5:= )
- jemalloc? ( dev-libs/jemalloc:=[${MULTILIB_USEDEP}] )
- utils? (
- ${SSL_DEPEND}
- >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
- net-dns/c-ares:=[${MULTILIB_USEDEP}]
- )
- xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${DISTDIR}"/${PN}-1.48.0-pthread.patch
- )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-examples
- --disable-failmalloc
- --disable-python-bindings
- --disable-werror
- --enable-threads
- --without-cython
- $(use_enable cxx asio-lib)
- $(use_enable debug)
- $(multilib_native_use_enable hpack-tools)
- $(use_enable static-libs static)
- $(use_with test cunit)
- $(multilib_native_use_enable utils app)
- $(multilib_native_use_with jemalloc)
- $(multilib_native_use_with xml libxml2)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- if ! use static-libs ; then
- find "${ED}"/usr -type f -name '*.la' -delete || die
- fi
-}