summaryrefslogtreecommitdiff
path: root/net-libs/nghttp2/nghttp2-1.48.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 19:46:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 19:46:11 +0100
commit1fd4e372381e1318aae1b7d3338c04156e5da974 (patch)
treed480b13516da01073c455f4a216a5645d4114190 /net-libs/nghttp2/nghttp2-1.48.0.ebuild
parent29607d91fb1bf1c4456a0b90601ee172ea769283 (diff)
gentoo auto-resync : 16:07:2022 - 19:46:10
Diffstat (limited to 'net-libs/nghttp2/nghttp2-1.48.0.ebuild')
-rw-r--r--net-libs/nghttp2/nghttp2-1.48.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-libs/nghttp2/nghttp2-1.48.0.ebuild b/net-libs/nghttp2/nghttp2-1.48.0.ebuild
index 97b642d84a6d..12c096a2127b 100644
--- a/net-libs/nghttp2/nghttp2-1.48.0.ebuild
+++ b/net-libs/nghttp2/nghttp2-1.48.0.ebuild
@@ -45,9 +45,15 @@ DEPEND="${RDEPEND}
test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-pthread.patch
+ )
+
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ # Restore when patch is merged/dropped
+ #[[ ${PV} == 9999 ]] && eautoreconf
+ eautoreconf
}
multilib_src_configure() {
@@ -61,6 +67,7 @@ multilib_src_configure() {
$(use_enable debug)
$(multilib_native_use_enable hpack-tools)
$(use_enable static-libs static)
+ $(use_with test cunit)
$(use_enable threads)
$(multilib_native_use_enable utils app)
$(multilib_native_use_with jemalloc)