summaryrefslogtreecommitdiff
path: root/net-libs/net6/net6-1.3.14-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/net6/net6-1.3.14-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/net6/net6-1.3.14-r2.ebuild')
-rw-r--r--net-libs/net6/net6-1.3.14-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/net6/net6-1.3.14-r2.ebuild b/net-libs/net6/net6-1.3.14-r2.ebuild
new file mode 100644
index 000000000000..b0af352cb3b8
--- /dev/null
+++ b/net-libs/net6/net6-1.3.14-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Network access framework for IPv4/IPv6 written in C++"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc x86"
+IUSE="nls static-libs"
+
+RDEPEND="dev-libs/libsigc++:2
+ >=net-libs/gnutls-1.2.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=(
+ "${FILESDIR}/${P}-gnutls-3.4.patch"
+)
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ elog "Please note that because of the use of C++ templates"
+ elog "Gobby 0.4 has to be recompiled against the new ${PN}"
+ elog "to pick up the changes."
+}