summaryrefslogtreecommitdiff
path: root/net-libs/miniupnpc/miniupnpc-1.9.20151008.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /net-libs/miniupnpc/miniupnpc-1.9.20151008.ebuild
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'net-libs/miniupnpc/miniupnpc-1.9.20151008.ebuild')
-rw-r--r--net-libs/miniupnpc/miniupnpc-1.9.20151008.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/net-libs/miniupnpc/miniupnpc-1.9.20151008.ebuild b/net-libs/miniupnpc/miniupnpc-1.9.20151008.ebuild
deleted file mode 100644
index 58d094ed95f9..000000000000
--- a/net-libs/miniupnpc/miniupnpc-1.9.20151008.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="UPnP client library and a simple UPnP client"
-HOMEPAGE="http://miniupnp.free.fr/"
-SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/14"
-KEYWORDS="amd64 arm hppa ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="ipv6 kernel_linux static-libs"
-
-RDEPEND=""
-DEPEND="kernel_linux? ( sys-apps/lsb-release sys-apps/which )"
-
-src_prepare() {
- epatch_user
-
- # These bins are not installed, upnpc-static requires building static lib
- # Reduce APIVERSION used to build SONAME since last API change was
- # backwards compatible to surprise of all the universe.
- sed -i -e '/EXECUTABLES =/s/ upnpc-static listdevices//' \
- -e '/APIVERSION/s:15:14:' Makefile || die
-
- if ! use static-libs; then
- sed -i \
- -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
- -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d' \
- Makefile || die
- fi
-}
-
-# Upstream cmake causes more trouble than it fixes,
-# so we'll just stay with the Makefile for now.
-
-src_compile() {
- tc-export CC AR
- emake upnpc-shared $(usex static-libs upnpc-static '')
-}
-
-src_test() {
- emake -j1 HAVE_IPV6=$(usex ipv6) check
-}
-
-src_install() {
- emake \
- PREFIX="${D}" \
- INSTALLDIRLIB="${D}usr/$(get_libdir)" \
- install
-
- dodoc README Changelog.txt
-}