summaryrefslogtreecommitdiff
path: root/net-libs/miniupnpc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /net-libs/miniupnpc/files
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'net-libs/miniupnpc/files')
-rw-r--r--net-libs/miniupnpc/files/miniupnpc-2.2.3-makefile.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/miniupnpc/files/miniupnpc-2.2.3-makefile.patch b/net-libs/miniupnpc/files/miniupnpc-2.2.3-makefile.patch
new file mode 100644
index 000000000000..7578bc3f8819
--- /dev/null
+++ b/net-libs/miniupnpc/files/miniupnpc-2.2.3-makefile.patch
@@ -0,0 +1,54 @@
+From ed1dc4bb5cdc4a53963f3eb01089289e30acc5a3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 29 Sep 2021 08:28:27 +0200
+Subject: [PATCH] Makefile: fix install rules to account for $(BUILD)
+
+Fix missing references to $(BUILD) in the install rules, as well
+as incorrect shared library symlink name. Otherwise, the 'install'
+phase fails either being unable to find files:
+
+ make: *** No rule to make target 'miniupnpc.pc', needed by 'install'. Stop.
+
+or trying to create the symlink in the wrong subdirectory:
+
+ ln: failed to create symbolic link '/tmp/z/usr/lib/build/libminiupnpc.so': No such file or directory
+---
+ miniupnpc/Makefile | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/miniupnpc/Makefile b/miniupnpc/Makefile
+index 4563b28..11a17f9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -162,7 +162,7 @@ PKGCONFIGDIR = $(INSTALLDIRLIB)/pkgconfig
+
+ FILESTOINSTALL = $(LIBRARY) $(EXECUTABLES)
+ ifeq (, $(findstring amiga, $(OS)))
+-FILESTOINSTALL += $(SHAREDLIBRARY) miniupnpc.pc
++FILESTOINSTALL += $(SHAREDLIBRARY) $(BUILD)/miniupnpc.pc
+ endif
+
+
+@@ -251,15 +251,15 @@ install: updateversion $(FILESTOINSTALL)
+ $(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)
+ ifeq (, $(findstring amiga, $(OS)))
+ $(INSTALL) -m 644 $(SHAREDLIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/$(SONAME)
+- ln -fs $(SONAME) $(DESTDIR)$(INSTALLDIRLIB)/$(SHAREDLIBRARY)
++ ln -fs $(SONAME) $(DESTDIR)$(INSTALLDIRLIB)/$(notdir $(SHAREDLIBRARY))
+ $(INSTALL) -d $(DESTDIR)$(PKGCONFIGDIR)
+- $(INSTALL) -m 644 miniupnpc.pc $(DESTDIR)$(PKGCONFIGDIR)
++ $(INSTALL) -m 644 $(BUILD)/miniupnpc.pc $(DESTDIR)$(PKGCONFIGDIR)
+ endif
+ $(INSTALL) -d $(DESTDIR)$(INSTALLDIRBIN)
+ ifneq (, $(findstring amiga, $(OS)))
+- $(INSTALL) -m 755 upnpc-static $(DESTDIR)$(INSTALLDIRBIN)/upnpc
++ $(INSTALL) -m 755 $(BUILD)/upnpc-static $(DESTDIR)$(INSTALLDIRBIN)/upnpc
+ else
+- $(INSTALL) -m 755 upnpc-shared $(DESTDIR)$(INSTALLDIRBIN)/upnpc
++ $(INSTALL) -m 755 $(BUILD)/upnpc-shared $(DESTDIR)$(INSTALLDIRBIN)/upnpc
+ endif
+ $(INSTALL) -m 755 external-ip.sh $(DESTDIR)$(INSTALLDIRBIN)/external-ip
+ ifeq (, $(findstring amiga, $(OS)))
+--
+2.33.0
+