summaryrefslogtreecommitdiff
path: root/net-libs/liquid-dsp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/liquid-dsp
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/liquid-dsp')
-rw-r--r--net-libs/liquid-dsp/Manifest4
-rw-r--r--net-libs/liquid-dsp/liquid-dsp-1.3.0.ebuild43
-rw-r--r--net-libs/liquid-dsp/liquid-dsp-9999.ebuild43
-rw-r--r--net-libs/liquid-dsp/metadata.xml15
4 files changed, 105 insertions, 0 deletions
diff --git a/net-libs/liquid-dsp/Manifest b/net-libs/liquid-dsp/Manifest
new file mode 100644
index 000000000000..35d5d6ab2160
--- /dev/null
+++ b/net-libs/liquid-dsp/Manifest
@@ -0,0 +1,4 @@
+DIST liquid-dsp-1.3.0.tar.gz 1036160 SHA256 b136343d644bc1441f7854f2d292bfa054e8d040c0b745879b205f6836dca0f0 SHA512 d69df2c15ea56cd84be9f77383b9914daa52e89e1136aa84fd14dff7690e98c4e29bb5c4e570cac5ef826b884b8fa382e5d806a711d22b6d5c4ddf5b93a0026b WHIRLPOOL ec0605293e5e0b8b1e276390b007ba8be871f23fdaafa6ec3e5dfb5fd54d1ca5c95b69b807ac4a91db63c673c0cf9df999db3c98bebc556fd4547b13388c8858
+EBUILD liquid-dsp-1.3.0.ebuild 1045 SHA256 23849fa64dc9e5e1f29545ce062d120497e931f8f529ed07405caf9f12936bfd SHA512 949fbf9e3e1e2b7e3f63e6636d41817d0be9942611adc37d02595b4a2cc7df998186fae286f9773f5f193eb6e6c9f1ae6461664d05275c4af3c3289795fb0d2a WHIRLPOOL 4eada6c632c3a566c72a39947603f2370083d2ea7ee1e1023ab3088a3d602b386f3de2167ef6a9950f94e3c393df6b5edc965aaa63bd8982729ff5832db9915d
+EBUILD liquid-dsp-9999.ebuild 1045 SHA256 23849fa64dc9e5e1f29545ce062d120497e931f8f529ed07405caf9f12936bfd SHA512 949fbf9e3e1e2b7e3f63e6636d41817d0be9942611adc37d02595b4a2cc7df998186fae286f9773f5f193eb6e6c9f1ae6461664d05275c4af3c3289795fb0d2a WHIRLPOOL 4eada6c632c3a566c72a39947603f2370083d2ea7ee1e1023ab3088a3d602b386f3de2167ef6a9950f94e3c393df6b5edc965aaa63bd8982729ff5832db9915d
+MISC metadata.xml 416 SHA256 f60116722af97d8e553abadbd27a86ac435f442686be454193bbd15fe806fe02 SHA512 7dee49689a60f0b24a9435987f3752f53c36c84187e19850bcbe5e2d14b1fd7bf52c3d8de83f91f3e25b3984bbbde9a08150b24d6b62552602ef145821bc95fe WHIRLPOOL 2d23541e01c8d5e76001b1cf4f5565c68bf7b58bfdca10608990fed73b57598b43fea954a92bdb43b0408172cf7c6aab838051ffa62b71589cc08cdc84758a79
diff --git a/net-libs/liquid-dsp/liquid-dsp-1.3.0.ebuild b/net-libs/liquid-dsp/liquid-dsp-1.3.0.ebuild
new file mode 100644
index 000000000000..fcd3127de23e
--- /dev/null
+++ b/net-libs/liquid-dsp/liquid-dsp-1.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib
+
+DESCRIPTION="digital signal processing library for software-defined radios"
+HOMEPAGE="http://liquidsdr.org"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jgaeddert/liquid-dsp.git"
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/jgaeddert/liquid-dsp/archive/v1.3.0.tar.gz -> ${P}.tar.gz"
+fi
+
+IUSE="static-libs"
+
+DEPEND="sci-libs/fftw:3.0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ #without this rather odd looking bit, it installs libraries into /usr/usr/$(get_libdir)
+ #what is super special is that if exec-prefix is unset, libdir is lib64...
+ #but if exec-prefix is default then libdir ends up as /usr/lib64 in makefile...
+ econf --exec-prefix="" --libdir="/usr/$(get_libdir)"
+}
+
+src_install() {
+ default
+ ! use static-libs && rm "${ED}"/usr/"$(get_libdir)"/libliquid.a
+}
diff --git a/net-libs/liquid-dsp/liquid-dsp-9999.ebuild b/net-libs/liquid-dsp/liquid-dsp-9999.ebuild
new file mode 100644
index 000000000000..fcd3127de23e
--- /dev/null
+++ b/net-libs/liquid-dsp/liquid-dsp-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib
+
+DESCRIPTION="digital signal processing library for software-defined radios"
+HOMEPAGE="http://liquidsdr.org"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jgaeddert/liquid-dsp.git"
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/jgaeddert/liquid-dsp/archive/v1.3.0.tar.gz -> ${P}.tar.gz"
+fi
+
+IUSE="static-libs"
+
+DEPEND="sci-libs/fftw:3.0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ #without this rather odd looking bit, it installs libraries into /usr/usr/$(get_libdir)
+ #what is super special is that if exec-prefix is unset, libdir is lib64...
+ #but if exec-prefix is default then libdir ends up as /usr/lib64 in makefile...
+ econf --exec-prefix="" --libdir="/usr/$(get_libdir)"
+}
+
+src_install() {
+ default
+ ! use static-libs && rm "${ED}"/usr/"$(get_libdir)"/libliquid.a
+}
diff --git a/net-libs/liquid-dsp/metadata.xml b/net-libs/liquid-dsp/metadata.xml
new file mode 100644
index 000000000000..a8b2258b537d
--- /dev/null
+++ b/net-libs/liquid-dsp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<maintainer type="project">
+<email>radio@gentoo.org</email>
+<name>Radio</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">jgaeddert/liquid-dsp</remote-id>
+</upstream>
+</pkgmetadata>