summaryrefslogtreecommitdiff
path: root/net-libs/libtrace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libtrace/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libtrace/files')
-rw-r--r--net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch11
-rw-r--r--net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch11
-rw-r--r--net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch21
-rw-r--r--net-libs/libtrace/files/libtrace-4.0.0-no-examples.patch10
-rw-r--r--net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch27
5 files changed, 80 insertions, 0 deletions
diff --git a/net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch b/net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch
new file mode 100644
index 000000000000..ed51ecb82868
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -61,7 +61,7 @@
+ ])
+
+ # Put all our automake definitions in config.h
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+
+ # Checks for C and C++ compilers
+ AC_PROG_CC
diff --git a/net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch b/net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch
new file mode 100644
index 000000000000..57983d036114
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ LIBPACKETDUMP_DIR = libpacketdump
+ TOOLS_DIR = tools
+ WANDIO_DIR=libwandio
+-SUBDIRS = $(WANDIO_DIR) lib $(LIBPACKETDUMP_DIR) $(TOOLS_DIR) docs examples
++SUBDIRS = $(WANDIO_DIR) lib $(LIBPACKETDUMP_DIR) $(TOOLS_DIR) docs
+
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = 1.9 foreign
diff --git a/net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch b/net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch
new file mode 100644
index 000000000000..9bda8a43b6b2
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/tools/tracetop/Makefile.am
++++ b/tools/tracetop/Makefile.am
+@@ -6,6 +6,6 @@
+ include ../Makefile.tools
+
+ tracetop_SOURCES = tracetop.cc
+-tracetop_LDADD = -lncurses
++tracetop_LDADD = @ncurses_LIBS@
+ tracetop_CPPFLAGS = -fno-strict-aliasing $(AM_CFLAGS)
+ endif
+--- a/configure.in
++++ b/configure.in
+@@ -492,6 +492,8 @@
+ fi
+ fi
+
++PKG_CHECK_MODULES(ncurses,ncurses)
++
+ AC_ARG_WITH([ncurses],
+ AC_HELP_STRING([--with-ncurses], [build tracetop (requires ncurses)]))
+
diff --git a/net-libs/libtrace/files/libtrace-4.0.0-no-examples.patch b/net-libs/libtrace/files/libtrace-4.0.0-no-examples.patch
new file mode 100644
index 000000000000..8467ffda24b0
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-4.0.0-no-examples.patch
@@ -0,0 +1,10 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,6 @@
+ LIBPACKETDUMP_DIR = libpacketdump
+ TOOLS_DIR = tools
+-SUBDIRS = lib $(LIBPACKETDUMP_DIR) $(TOOLS_DIR) docs examples
++SUBDIRS = lib $(LIBPACKETDUMP_DIR) $(TOOLS_DIR) docs
+
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = 1.9 foreign
diff --git a/net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch b/net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch
new file mode 100644
index 000000000000..54e9f54f8dc1
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-4.0.0-with-numa.patch
@@ -0,0 +1,27 @@
+--- a/configure.in
++++ b/configure.in
+@@ -431,7 +431,23 @@
+ [[#include <linux/if_packet.h>]])
+
+ # If we use DPDK we might be able to use libnuma
+-AC_CHECK_LIB(numa, numa_node_to_cpus, have_numa=1, have_numa=0)
++AC_ARG_WITH(numa,
++ AS_HELP_STRING(--with-numa,include NUMA support),
++[
++ if test "$withval" = no
++ then
++ want_numa=no
++ else
++ want_numa=yes
++ fi
++],[
++ # Default to building without NUMA
++ want_numa=yes
++])
++
++if test "$want_numa" != no; then
++ AC_CHECK_LIB(numa, numa_node_to_cpus, have_numa=1, have_numa=0)
++fi
+
+ # Checks for various "optional" libraries
+ AC_CHECK_LIB(pthread, pthread_create, have_pthread=1, have_pthread=0)