summaryrefslogtreecommitdiff
path: root/net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
commit76cba73c47c8694e74377004634daca18f2d9c08 (patch)
tree468603ebdc189bcfae77696162761b3be936baea /net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild
parent6957f5c65b02bba533954eabc0b62f5de36be206 (diff)
gentoo resync : 14.04.2018
Diffstat (limited to 'net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild')
-rw-r--r--net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild b/net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild
new file mode 100644
index 000000000000..23605ce88036
--- /dev/null
+++ b/net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vcs-snapshot
+
+DESCRIPTION="A simple C language RPC framework"
+HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
+#TODO: Use commit hash tarball on next version bump.
+SRC_URI="https://github.com/haiwen/${PN}/archive/v3.1-latest.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/jansson-2.2.1"
+RDEPEND="${DEPEND}
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"usr/bin
+}