summaryrefslogtreecommitdiff
path: root/net-libs/librsync/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/librsync/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/librsync/files')
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-fix-testsuite.patch15
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-format-security.patch20
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-getopt.patch17
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-huge-files.patch31
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch19
-rw-r--r--net-libs/librsync/files/librsync-2.0.0-search.patch12
6 files changed, 114 insertions, 0 deletions
diff --git a/net-libs/librsync/files/librsync-0.9.7-fix-testsuite.patch b/net-libs/librsync/files/librsync-0.9.7-fix-testsuite.patch
new file mode 100644
index 000000000000..e87c3d8f67b5
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-fix-testsuite.patch
@@ -0,0 +1,15 @@
+Description: Fix running tests with the parallel harness
+Author: Andrey Rahmatullin <wrar@wrar.name>
+Last-Update: 2013-06-26
+
+--- a/testsuite/Makefile.am
++++ b/testsuite/Makefile.am
+@@ -29,7 +29,7 @@ isprefix_driver_LDADD = ../isprefix.o # XXX: should link replaced functions
+ # failed. Generally these tests should be ordered so that more basic
+ # tests are run first.
+
+-TESTS_ENVIRONMENT = $(SH) $(srcdir)/driver.sh
++TEST_LOG_COMPILER = $(SH) $(srcdir)/driver.sh
+
+ TESTS = \
+ signature.test mutate.test sources.test isprefix.test \
diff --git a/net-libs/librsync/files/librsync-0.9.7-format-security.patch b/net-libs/librsync/files/librsync-0.9.7-format-security.patch
new file mode 100644
index 000000000000..e35980a4d7a0
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-format-security.patch
@@ -0,0 +1,20 @@
+Description: Always use a format string in printf
+ Fix the warning: buf.c:216:9: error: format not a string literal and no
+ format arguments [-Werror=format-security]
+Author: Andrey Rahmatullin <wrar@wrar.name>
+Forwarded: no
+Last-Update: 2012-02-05
+
+diff --git a/buf.c b/buf.c
+index 7f4e7a0..3a83f2b 100644
+--- a/buf.c
++++ b/buf.c
+@@ -213,7 +213,7 @@ rs_result rs_file_copy_cb(void *arg, rs_long_t pos, size_t *len, void **buf)
+
+ got = fread(*buf, 1, *len, f);
+ if (got == -1) {
+- rs_error(strerror(errno));
++ rs_error("%s", strerror(errno));
+ return RS_IO_ERROR;
+ } else if (got == 0) {
+ rs_error("unexpected eof on fd%d", fileno(f));
diff --git a/net-libs/librsync/files/librsync-0.9.7-getopt.patch b/net-libs/librsync/files/librsync-0.9.7-getopt.patch
new file mode 100644
index 000000000000..0859089b970a
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-getopt.patch
@@ -0,0 +1,17 @@
+Patch by Daniel Baumann <daniel@debian.org> for librsync >= 0.9.7, which makes
+rdiff aware of -i and -z getopt options mentioned in --help output. For further
+information, please have a look to Debian bug ID #435894.
+
+--- librsync-0.9.7/rdiff.c 2004-09-17 23:35:50.000000000 +0200
++++ librsync-0.9.7/rdiff.c.getopt 2008-12-20 13:45:58.000000000 +0100
+@@ -97,8 +97,8 @@
+ { "sum-size", 'S', POPT_ARG_INT, &strong_len },
+ { "statistics", 's', POPT_ARG_NONE, &show_stats },
+ { "stats", 0, POPT_ARG_NONE, &show_stats },
+- { "gzip", 0, POPT_ARG_NONE, 0, OPT_GZIP },
+- { "bzip2", 0, POPT_ARG_NONE, 0, OPT_BZIP2 },
++ { "gzip", 'z', POPT_ARG_NONE, 0, OPT_GZIP },
++ { "bzip2", 'i', POPT_ARG_NONE, 0, OPT_BZIP2 },
+ { "paranoia", 0, POPT_ARG_NONE, &rs_roll_paranoia },
+ { 0 }
+ };
diff --git a/net-libs/librsync/files/librsync-0.9.7-huge-files.patch b/net-libs/librsync/files/librsync-0.9.7-huge-files.patch
new file mode 100644
index 000000000000..fef08941a44f
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-huge-files.patch
@@ -0,0 +1,31 @@
+diff -urN librsync-0.9.7/mdfour.h librsync-0.9.7dev/mdfour.h
+--- librsync-0.9.7/mdfour.h 2004-02-07 18:17:57.000000000 -0500
++++ librsync-0.9.7dev/mdfour.h 2006-03-06 03:21:46.000000000 -0500
+@@ -24,7 +24,7 @@
+ #include "types.h"
+
+ struct rs_mdfour {
+- int A, B, C, D;
++ unsigned int A, B, C, D;
+ #if HAVE_UINT64
+ uint64_t totalN;
+ #else
+diff -urN librsync-0.9.7/patch.c librsync-0.9.7dev/patch.c
+--- librsync-0.9.7/patch.c 2004-09-17 17:35:50.000000000 -0400
++++ librsync-0.9.7dev/patch.c 2006-03-06 03:21:06.000000000 -0500
+@@ -214,12 +214,12 @@
+ void *buf, *ptr;
+ rs_buffers_t *buffs = job->stream;
+
+- len = job->basis_len;
+-
+ /* copy only as much as will fit in the output buffer, so that we
+ * don't have to block or store the input. */
+- if (len > buffs->avail_out)
++ if (job->basis_len > buffs->avail_out)
+ len = buffs->avail_out;
++ else
++ len = job->basis_len;
+
+ if (!len)
+ return RS_BLOCKED;
diff --git a/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch b/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch
new file mode 100644
index 000000000000..782597c8fe2b
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch
@@ -0,0 +1,19 @@
+Description: Fix -Wimplicit-function-declaration warning in the test suite
+ Fix the warning: isprefix.driver.c:43:5: warning: implicit declaration of
+ function ‘strcmp’ [-Wimplicit-function-declaration]
+Author: Andrey Rahmatullin <wrar@wrar.name>
+Forwarded: no
+Last-Update: 2012-02-05
+
+diff --git a/testsuite/isprefix.driver.c b/testsuite/isprefix.driver.c
+index a9fd77b..df558c2 100644
+--- a/testsuite/isprefix.driver.c
++++ b/testsuite/isprefix.driver.c
+@@ -21,6 +21,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "isprefix.h"
+
diff --git a/net-libs/librsync/files/librsync-2.0.0-search.patch b/net-libs/librsync/files/librsync-2.0.0-search.patch
new file mode 100644
index 000000000000..93b4106ee8b5
--- /dev/null
+++ b/net-libs/librsync/files/librsync-2.0.0-search.patch
@@ -0,0 +1,12 @@
+diff -Naur a/src/search.c b/src/search.c
+--- a/src/search.c 2015-11-29 21:43:12.000000000 +0100
++++ b/src/search.c 2016-01-31 19:11:54.847933060 +0100
+@@ -218,7 +218,7 @@
+ r = m;
+ }
+
+- if (l == r) {
++ if ((l == r) && (l <= bucket->r)) {
+ int i = sig->targets[l].i;
+ rs_block_sig_t *b = &(sig->block_sigs[i]);
+ if (weak_sum != b->weak_sum)