summaryrefslogtreecommitdiff
path: root/net-libs/librouteros/librouteros-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /net-libs/librouteros/librouteros-1.1.2.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'net-libs/librouteros/librouteros-1.1.2.ebuild')
-rw-r--r--net-libs/librouteros/librouteros-1.1.2.ebuild30
1 files changed, 20 insertions, 10 deletions
diff --git a/net-libs/librouteros/librouteros-1.1.2.ebuild b/net-libs/librouteros/librouteros-1.1.2.ebuild
index 9e89899c90e7..a6be5fce2804 100644
--- a/net-libs/librouteros/librouteros-1.1.2.ebuild
+++ b/net-libs/librouteros/librouteros-1.1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit base autotools-utils autotools
+inherit autotools
DESCRIPTION="Library for accessing MikroTik's RouterOS via its API"
HOMEPAGE="http://verplant.org/librouteros/"
@@ -12,15 +12,25 @@ SRC_URI="http://verplant.org/librouteros/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="debug static-libs"
+IUSE="debug"
-DEPEND="dev-libs/libgcrypt:0"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-libs/libgcrypt:0="
+DEPEND="${RDEPEND}"
-DOCS=(README AUTHORS)
-PATCHES=("${FILESDIR}"/disable_werror.patch)
+PATCHES=( "${FILESDIR}"/${P}-remove-Werror.patch )
-src_prepare(){
- base_src_prepare
+src_prepare() {
+ default
eautoreconf
}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}