summaryrefslogtreecommitdiff
path: root/net-libs/libquotient/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
commitd12ee3457fd1a8bf18ede06882314fc1df30bd4b (patch)
tree33d42f682bfdfdf5fc26dd6bdd779853b8441ca0 /net-libs/libquotient/files
parent53aea9d709c9286028405b25584181507f47442f (diff)
gentoo auto-resync : 31:07:2023 - 16:45:16
Diffstat (limited to 'net-libs/libquotient/files')
-rw-r--r--net-libs/libquotient/files/libquotient-0.8.0-no-android.patch29
-rw-r--r--net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch34
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
new file mode 100644
index 000000000000..5b2e34123226
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
@@ -0,0 +1,29 @@
+From ad928b9f34f5e6f42c8555a0a502c35de6cb86b5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 3 Jan 2021 15:18:01 +0100
+Subject: [PATCH 1/2] Install EXPORT_ANDROID_MK only if(ANDROID)
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0a32ee4e..7e03085f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -387,7 +387,10 @@ install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_NAME}/${QUOTIENT_LIB_NAME}ConfigVersion.cmake"
+ DESTINATION ${CMakeFilesLocation}
+ )
+-install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++
++if (ANDROID)
++ install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++endif ()
+
+ if (WIN32)
+ install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)
+--
+2.41.0
+
diff --git a/net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch b/net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch
new file mode 100644
index 000000000000..96fe1029c826
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch
@@ -0,0 +1,34 @@
+From c35f062d1c9975ec0bdfdcbcdeb6b9973b73f86b Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 24 Dec 2022 22:51:12 +0100
+Subject: [PATCH 2/2] Put Qt5Test dependency behind -DBUILD_TESTING
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7e03085f..f2ab0ae7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,7 +92,7 @@ else()
+ set(QtExtraModules "Multimedia") # See #483
+ endif()
+ string(REGEX REPLACE "^(.).*" "Qt\\1" Qt ${QtMinVersion}) # makes "Qt5" or "Qt6"
+-find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui Test ${QtExtraModules})
++find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui ${QtExtraModules})
+ get_filename_component(Qt_Prefix "${${Qt}_DIR}/../../../.." ABSOLUTE)
+
+ find_package(${Qt}Keychain REQUIRED)
+@@ -344,6 +344,7 @@ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_
+ # Configure testing
+
+ if (BUILD_TESTING)
++ find_package(${Qt}Test ${QtMinVersion} REQUIRED)
+ enable_testing()
+ add_subdirectory(quotest)
+ add_subdirectory(autotests)
+--
+2.41.0
+