summaryrefslogtreecommitdiff
path: root/net-libs/libpsl/libpsl-0.21.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 17:31:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 17:31:39 +0100
commit8b5a92f1e1eccecfa61db8a4744e1b9d449522b6 (patch)
tree427b7c54371dc36d63e7fa3590ec577ad265eac9 /net-libs/libpsl/libpsl-0.21.2.ebuild
parent3023707d355581e5dc6945aa9c8f4d59e508a8b5 (diff)
gentoo auto-resync : 05:05:2023 - 17:31:39
Diffstat (limited to 'net-libs/libpsl/libpsl-0.21.2.ebuild')
-rw-r--r--net-libs/libpsl/libpsl-0.21.2.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-libs/libpsl/libpsl-0.21.2.ebuild b/net-libs/libpsl/libpsl-0.21.2.ebuild
index 221ce7a987cc..8dba8ae8ee92 100644
--- a/net-libs/libpsl/libpsl-0.21.2.ebuild
+++ b/net-libs/libpsl/libpsl-0.21.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit meson-multilib python-any-r1
DESCRIPTION="C library for the Public Suffix List"
@@ -13,7 +13,8 @@ SRC_URI="https://github.com/rockdaboot/${PN}/releases/download/${PV}/${P}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="icu +idn"
+IUSE="icu +idn test"
+RESTRICT="!test? ( test )"
RDEPEND="
icu? ( !idn? ( dev-libs/icu:=[${MULTILIB_USEDEP}] ) )
@@ -29,6 +30,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-tests-optional.patch
+)
+
pkg_pretend() {
if use icu && use idn ; then
ewarn "\"icu\" and \"idn\" USE flags are enabled. Using \"idn\"."
@@ -36,7 +41,9 @@ pkg_pretend() {
}
multilib_src_configure() {
- local emesonargs=()
+ local emesonargs=(
+ $(meson_use test tests)
+ )
# Prefer idn even if icu is in USE as well
if use idn ; then