summaryrefslogtreecommitdiff
path: root/net-libs/libprotoident/libprotoident-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libprotoident/libprotoident-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libprotoident/libprotoident-9999.ebuild')
-rw-r--r--net-libs/libprotoident/libprotoident-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libprotoident/libprotoident-9999.ebuild b/net-libs/libprotoident/libprotoident-9999.ebuild
new file mode 100644
index 000000000000..522c59fb2667
--- /dev/null
+++ b/net-libs/libprotoident/libprotoident-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils git-r3
+
+DESCRIPTION="A library that performs application layer protocol identification for flows"
+HOMEPAGE="http://research.wand.net.nz/software/libprotoident.php"
+EGIT_REPO_URI="https://github.com/wanduow/libprotoident"
+EGIT_BRANCH="develop"
+
+LICENSE="LGPL-3+"
+SLOT="0/2"
+KEYWORDS=""
+IUSE="static-libs +tools"
+
+DEPEND="
+ >=net-libs/libtrace-4.0.1
+ >=net-libs/libflowmanager-3.0.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -i -e '/-Werror/d' lib/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}