summaryrefslogtreecommitdiff
path: root/net-libs/libprotoident/libprotoident-2.0.14_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-libs/libprotoident/libprotoident-2.0.14_p1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-libs/libprotoident/libprotoident-2.0.14_p1.ebuild')
-rw-r--r--net-libs/libprotoident/libprotoident-2.0.14_p1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libprotoident/libprotoident-2.0.14_p1.ebuild b/net-libs/libprotoident/libprotoident-2.0.14_p1.ebuild
new file mode 100644
index 000000000000..5ab401137bbc
--- /dev/null
+++ b/net-libs/libprotoident/libprotoident-2.0.14_p1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A library that performs application layer protocol identification for flows"
+HOMEPAGE="https://research.wand.net.nz/software/libprotoident.php"
+SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs tools"
+
+DEPEND="
+ >=net-libs/libtrace-4.0.1
+ >=net-libs/libflowmanager-3.0.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-Werror/d' \
+ lib/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}