summaryrefslogtreecommitdiff
path: root/net-libs/libosip/libosip-3.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /net-libs/libosip/libosip-3.6.0.ebuild
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'net-libs/libosip/libosip-3.6.0.ebuild')
-rw-r--r--net-libs/libosip/libosip-3.6.0.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/net-libs/libosip/libosip-3.6.0.ebuild b/net-libs/libosip/libosip-3.6.0.ebuild
index 54f60c8218a2..814555da67d5 100644
--- a/net-libs/libosip/libosip-3.6.0.ebuild
+++ b/net-libs/libosip/libosip-3.6.0.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils autotools
+inherit autotools
MY_PV=${PV%.?}-${PV##*.}
MY_PV=${PV}
MY_P=${PN}2-${MY_PV}
+
DESCRIPTION="a simple way to support the Session Initiation Protocol"
HOMEPAGE="https://www.gnu.org/software/osip/"
SRC_URI="mirror://gnu/osip/${MY_P}.tar.gz"
@@ -19,8 +20,10 @@ IUSE="test"
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}/${PN}-3.3.0-out-source-build.patch" )
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-3.3.0-out-source-build.patch"
+ default
AT_M4DIR="scripts" eautoreconf
}
@@ -28,8 +31,3 @@ src_configure() {
econf --enable-mt \
$(use_enable test)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- dodoc AUTHORS ChangeLog FEATURES HISTORY README NEWS TODO || die
-}