summaryrefslogtreecommitdiff
path: root/net-libs/libnsl/libnsl-1.1.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /net-libs/libnsl/libnsl-1.1.0-r3.ebuild
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'net-libs/libnsl/libnsl-1.1.0-r3.ebuild')
-rw-r--r--net-libs/libnsl/libnsl-1.1.0-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/libnsl/libnsl-1.1.0-r3.ebuild b/net-libs/libnsl/libnsl-1.1.0-r3.ebuild
new file mode 100644
index 000000000000..a6b602365fd5
--- /dev/null
+++ b/net-libs/libnsl/libnsl-1.1.0-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Public client interface for NIS(YP) and NIS+ in a IPv6 ready version"
+HOMEPAGE="https://github.com/thkukuk/libnsl"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/${P}.tar.gz"
+
+SLOT="0/2"
+LICENSE="LGPL-2.1+"
+
+# Stabilize together with glibc-2.26!
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE=""
+
+DEPEND="
+ net-libs/libtirpc[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<sys-libs/glibc-2.26
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare(){
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}