summaryrefslogtreecommitdiff
path: root/net-libs/libhtp/libhtp-0.5.38.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /net-libs/libhtp/libhtp-0.5.38.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'net-libs/libhtp/libhtp-0.5.38.ebuild')
-rw-r--r--net-libs/libhtp/libhtp-0.5.38.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libhtp/libhtp-0.5.38.ebuild b/net-libs/libhtp/libhtp-0.5.38.ebuild
new file mode 100644
index 000000000000..52f8e32728c6
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.38.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+ fi
+}