summaryrefslogtreecommitdiff
path: root/net-libs/libhackrf/libhackrf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 21:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 21:23:22 +0100
commit15a738a098c486b6ec6d624050dd98826f9c2d3f (patch)
tree7b170748ee082c6db9b27bbc34b34b27e2e9873b /net-libs/libhackrf/libhackrf-9999.ebuild
parent3a2444aaf0bafd5c58c0dc8dda102352f20c76d8 (diff)
gentoo auto-resync : 29:09:2022 - 21:23:22
Diffstat (limited to 'net-libs/libhackrf/libhackrf-9999.ebuild')
-rw-r--r--net-libs/libhackrf/libhackrf-9999.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/net-libs/libhackrf/libhackrf-9999.ebuild b/net-libs/libhackrf/libhackrf-9999.ebuild
index aacd79049ae5..586e9f4bd1ec 100644
--- a/net-libs/libhackrf/libhackrf-9999.ebuild
+++ b/net-libs/libhackrf/libhackrf-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
@@ -16,7 +16,7 @@ if [[ ${PV} == "9999" ]] ; then
else
S="${WORKDIR}/hackrf-${PV}/host/libhackrf"
SRC_URI="https://github.com/greatscottgadgets/hackrf/releases/download/v${PV}/hackrf-${PV}.tar.xz"
- KEYWORDS="~amd64 ~arm ~ppc ~x86"
+ KEYWORDS="~amd64 ~arm ~ppc ~riscv ~x86"
fi
LICENSE="BSD"
@@ -26,6 +26,9 @@ IUSE="+udev"
DEPEND="virtual/libusb:1"
RDEPEND="${DEPEND}"
+# https://github.com/greatscottgadgets/hackrf/issues/1193
+PATCHES=( "${FILESDIR}/hackrf-disable-static-${PV}.patch" )
+
src_configure() {
local mycmakeargs=(
-DINSTALL_UDEV_RULES="$(usex udev)"
@@ -40,5 +43,12 @@ src_configure() {
}
pkg_postinst() {
- use udev && einfo "Users in the usb group can use hackrf."
+ if use udev; then
+ einfo "Users in the usb group can use hackrf."
+ udev_reload
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
}