summaryrefslogtreecommitdiff
path: root/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild')
-rw-r--r--net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild b/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
index f1337c58b2d1..9891a9aa4448 100644
--- a/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
+++ b/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils ltprune
+EAPI=7
DESCRIPTION="A library that measures and reports on packet flows"
HOMEPAGE="https://research.wand.net.nz/software/libflowmanager.php"
@@ -11,24 +10,20 @@ SRC_URI="https://research.wand.net.nz/software/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/3"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-DEPEND="
- >=net-libs/libtrace-3.0.6
-"
-RDEPEND="
- ${DEPEND}
-"
+
+DEPEND=">=net-libs/libtrace-3.0.6"
+RDEPEND="${DEPEND}"
+
PATCHES=(
"${FILESDIR}"/${PN}-3.0.0-stdint_h.patch
)
src_configure() {
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}