summaryrefslogtreecommitdiff
path: root/net-libs/libeXosip/libeXosip-3.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /net-libs/libeXosip/libeXosip-3.5.0.ebuild
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'net-libs/libeXosip/libeXosip-3.5.0.ebuild')
-rw-r--r--net-libs/libeXosip/libeXosip-3.5.0.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/net-libs/libeXosip/libeXosip-3.5.0.ebuild b/net-libs/libeXosip/libeXosip-3.5.0.ebuild
index 322a25facbbe..3f2fed0aaf0a 100644
--- a/net-libs/libeXosip/libeXosip-3.5.0.ebuild
+++ b/net-libs/libeXosip/libeXosip-3.5.0.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-
-inherit eutils
+EAPI=6
MY_PV=${PV%.?}-${PV##*.}
MY_PV=${PV}
MY_P=${PN}2-${MY_PV}
+
DESCRIPTION="library to use the SIP protocol for multimedia session establishement"
HOMEPAGE="https://savannah.nongnu.org/projects/exosip/"
SRC_URI="mirror://nongnu/exosip/${MY_P}.tar.gz"
@@ -15,11 +14,15 @@ SRC_URI="mirror://nongnu/exosip/${MY_P}.tar.gz"
KEYWORDS="amd64 ppc x86 ~ppc-macos ~x86-macos"
SLOT="0"
LICENSE="GPL-2"
-IUSE="+srv ssl"
+IUSE="libressl +srv ssl"
DEPEND=">=net-libs/libosip-3.2.0
<net-libs/libosip-4
- ssl? ( dev-libs/openssl )"
+ ssl? (
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ )
+"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
@@ -30,8 +33,3 @@ src_configure() {
$(use_enable ssl openssl) \
$(use_enable srv srvrec)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README
-}