summaryrefslogtreecommitdiff
path: root/net-libs/libcrafter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libcrafter
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libcrafter')
-rw-r--r--net-libs/libcrafter/Manifest6
-rw-r--r--net-libs/libcrafter/libcrafter-0.3.ebuild37
-rw-r--r--net-libs/libcrafter/libcrafter-9999.ebuild37
-rw-r--r--net-libs/libcrafter/metadata.xml36
4 files changed, 116 insertions, 0 deletions
diff --git a/net-libs/libcrafter/Manifest b/net-libs/libcrafter/Manifest
new file mode 100644
index 000000000000..912919d0a5fb
--- /dev/null
+++ b/net-libs/libcrafter/Manifest
@@ -0,0 +1,6 @@
+DIST libcrafter-0.3.tar.gz 104051 SHA256 4608b10470aaa5a711b13b7c9db93fc6c3daca8c26ae7e81b0d7aa8af3a497aa SHA512 7c396ba942b304dddfaa569adb44697f75568d3ef2ed48dda758e281f3b7c172439309033bbf5498069a4a61a952f93e41af99b129ce874ce76b5ec08da58116 WHIRLPOOL 9444ba34eb9c0f4072bb52d1bc1a0712e274c344af61059f60f626a4465476d65606918bb759e236c97bb8c49733e498f9fa8593862058fb0e0aa397bf489eea
+EBUILD libcrafter-0.3.ebuild 658 SHA256 c90af20878393aa6a388cebd764750b8c5e2d61f7076b67f7428bcab7e792266 SHA512 3a8b09162802b69465e798b52e13c291e1d9521807a37b4e3fc4f2988e5581985a8270decd9b8ce1786371d3b07d0e79aae599c60e6ddc94cd5c46e14c9ab6cc WHIRLPOOL 4cc57f43a43386237b9ef353d0973cc9125fac81121b04a7f5bc80bbda2743a9d38ad4ae60cfa2d916b2e77e7b4d3a79f75e84c90280fe23f3d7e3d19aa7e428
+EBUILD libcrafter-9999.ebuild 637 SHA256 f7c33d79451651c906785391dad813d5b7315a8ad3c62b43a32716ca8cc6909b SHA512 6d8ec46b293ce4cf17236b00f07cc01795d536577027d7bcab42128446dfe80d734270401a93719ad95de394490025f86c2ddd1c4f86030309eeb026accc62b7 WHIRLPOOL 6a88f284b55c095ae31b198241a5aabf153b80dc8e088878ab197cc9a9b1acf7eaf3802bba41475b95605e69eb03ee552a6bd06a1392e2218745852712d6d56c
+MISC ChangeLog 2942 SHA256 3f1eecf4ceb99c8b8f6e942ac46a62fe77cae5d8b4086a26c13d5a60bf204c82 SHA512 03f350a032275ef9df1d72694c147a550a3719ccc4f11c725971170ed50d86c94e5958bc01584352c6e7de5ec9de59aa7328974cb575c6c4d57b61955b6e4ed5 WHIRLPOOL 8b35245e3f6386e600c943b04fdcc1eb3e931103e7bbf7c6be0aab10cab685e50f316ea16e1c82bd5bf1a837c8c44ee5d8b529fb9d9c0b3aef46f29a884ec73e
+MISC ChangeLog-2015 1062 SHA256 1c61f79f440d319de66dc3c7e22b216cf1eac941784dc584d9ec11ab7a58a2a1 SHA512 e12c2c3aa92b4ee294f5df359a398eac667f2342a6544c9b93b954fabbba5042f89330d883e7ba9c430d9a45126bb36212f316051153394444343d608cf9753f WHIRLPOOL 569cde5be8134038c40fa9dd78497993413f84084f78d67e6e101dba270b5ac36d325fe01f69531960cbba8f7d06c74f62b05c031300c3faf122d3c19b66aacf
+MISC metadata.xml 1647 SHA256 ba8cff4e6d3857cf23b028b72e3005493dc7fc57be058a3650f619855545c3b9 SHA512 6e1ee9e3402a26c3981552ff8fd7193f75dae388fb6d1e59739e1cc4e6f027c995cc68b1984fc13d39d56c152fee6b4b6ee82c9c79f6033627b5e9e0261bdc87 WHIRLPOOL d160a5b7253236a6aecfcc257194ea0d46bd60a06157addbab3c06900eb9fccb4693affd58cec91c83533b4bcb1eb463c57d6d8c7b57de6d630001125d734a13
diff --git a/net-libs/libcrafter/libcrafter-0.3.ebuild b/net-libs/libcrafter/libcrafter-0.3.ebuild
new file mode 100644
index 000000000000..aafb4400f9e0
--- /dev/null
+++ b/net-libs/libcrafter/libcrafter-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A high level C++ network packet sniffing and crafting library"
+HOMEPAGE="https://github.com/pellegre/libcrafter"
+SRC_URI="https://github.com/pellegre/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${PN}-version-${PV}/${PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}
diff --git a/net-libs/libcrafter/libcrafter-9999.ebuild b/net-libs/libcrafter/libcrafter-9999.ebuild
new file mode 100644
index 000000000000..561ca127a53c
--- /dev/null
+++ b/net-libs/libcrafter/libcrafter-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils git-r3
+
+DESCRIPTION="a high level library for C++ designed to make easier the creation and decoding of network packets"
+HOMEPAGE="https://github.com/pellegre/libcrafter"
+EGIT_REPO_URI="https://github.com/pellegre/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}
diff --git a/net-libs/libcrafter/metadata.xml b/net-libs/libcrafter/metadata.xml
new file mode 100644
index 000000000000..a6af28bc39c2
--- /dev/null
+++ b/net-libs/libcrafter/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+ </maintainer>
+ <longdescription lang="en">
+Libcrafter is a high level library for C++ designed to facilitate the creation
+and decoding of network packets. It is able to craft or decode packets of most
+common networks protocols, send them on the wire, capture them and match
+requests and replies.
+It enables the creation of networking tools in a few lines with a interface
+very similar to <pkg>net-analyzer/scapy</pkg>.
+A packet is described as layers that you stack one upon the other. Fields of
+each layer have useful default values that you can overload.
+
+The library is designed to be used in multithreaded programs where you can
+combine several tasks simultaneously. For example, you can easily design
+something that sniffs, mangles, and sends at the same time you are doing an
+ARP-Spoofing attack.
+It also contains a very naive implementation of the TCP/IP stack (fragmentation
+is no handled yet) at user level that enables working with TCP streams. This
+facilitates the creation of tools for data injection on arbitrary connections,
+IP spoofing and TCP/IP session hijacking.
+
+Supported protocols are:
+
+Ethernet, SLL (Linux cooked-mode capture), ARP, DHCP, DHCP options, IP, IP
+options, IPv6, ICMP, ICMPv6, ICMP extensions, ICMPv6 extensions, TCP, TCP
+options, UDP and DNS
+</longdescription>
+ <upstream>
+ <remote-id type="github">pellegre/libcrafter</remote-id>
+ </upstream>
+</pkgmetadata>