summaryrefslogtreecommitdiff
path: root/net-libs/libcorkipset/libcorkipset-1.1.1.20150311_p8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /net-libs/libcorkipset/libcorkipset-1.1.1.20150311_p8.ebuild
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'net-libs/libcorkipset/libcorkipset-1.1.1.20150311_p8.ebuild')
-rw-r--r--net-libs/libcorkipset/libcorkipset-1.1.1.20150311_p8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/libcorkipset/libcorkipset-1.1.1.20150311_p8.ebuild b/net-libs/libcorkipset/libcorkipset-1.1.1.20150311_p8.ebuild
new file mode 100644
index 000000000000..fd8b1f855364
--- /dev/null
+++ b/net-libs/libcorkipset/libcorkipset-1.1.1.20150311_p8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DATE=20150311
+MY_PV="${PV/.${DATE}_p/+${DATE}-}"
+MY_PX="${PV/.${DATE}_p/-${DATE}-}"
+
+DESCRIPTION="A small C helper library for storing sets of IPv4 and IPv6 addresses"
+HOMEPAGE="https://github.com/rogers0/libcorkipset"
+SRC_URI="https://github.com/rogers0/${PN}/archive/debian/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libcork"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-debian-${MY_PX}"
+
+src_prepare() {
+ rm -f "${S}"/debian/patches/0001*.patch || die
+ eapply "${S}"/debian/patches/*.patch
+
+ sed -e 's%#include <ipset%#include <libcorkipset%' \
+ -e 's%#include "ipset%#include "libcorkipset%' \
+ -i include/ipset/*.h \
+ */*/*/*.c \
+ */*/*/*.c.in \
+ */*/*.c */*.c || die
+
+ mv include/{,libcork}ipset || die
+
+ cmake-utils_src_prepare
+}