summaryrefslogtreecommitdiff
path: root/net-libs/libbtbb/libbtbb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-libs/libbtbb/libbtbb-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-libs/libbtbb/libbtbb-9999.ebuild')
-rw-r--r--net-libs/libbtbb/libbtbb-9999.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/net-libs/libbtbb/libbtbb-9999.ebuild b/net-libs/libbtbb/libbtbb-9999.ebuild
index a1587cd739a2..edbf18eed8ff 100644
--- a/net-libs/libbtbb/libbtbb-9999.ebuild
+++ b/net-libs/libbtbb/libbtbb-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit multilib cmake-utils
+inherit cmake
DESCRIPTION="A library to decode Bluetooth baseband packets"
HOMEPAGE="http://libbtbb.sourceforge.net/"
@@ -47,7 +47,7 @@ which_plugins() {
src_prepare() {
CMAKE_USE_DIR="${S}"
BUILD_DIR="${S}"_build
- cmake-utils_src_prepare
+ cmake_src_prepare
if use wireshark-plugins; then
which_plugins
@@ -60,7 +60,7 @@ src_prepare() {
CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
fi
BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_prepare
+ cmake_src_prepare
done
fi
}
@@ -73,7 +73,7 @@ src_configure() {
-DBUILD_STATIC_LIB=$(usex static-libs)
-DBUILD_ROOT="${ED}"
)
- cmake-utils_src_configure
+ cmake_src_configure
if use wireshark-plugins; then
for i in ${plugins}
@@ -87,7 +87,7 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
)
- cmake-utils_src_configure
+ cmake_src_configure
done
fi
}
@@ -95,7 +95,7 @@ src_configure() {
src_compile() {
CMAKE_USE_DIR="${S}"
BUILD_DIR="${S}"_build
- cmake-utils_src_compile
+ cmake_src_compile
if use wireshark-plugins; then
for i in ${plugins}
@@ -106,7 +106,7 @@ src_compile() {
CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
fi
BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_compile
+ cmake_src_compile
done
fi
}
@@ -114,7 +114,7 @@ src_compile() {
src_test() {
CMAKE_USE_DIR="${S}"
BUILD_DIR="${S}"_build
- cmake-utils_src_test
+ cmake_src_test
if use wireshark-plugins; then
for i in ${plugins}
@@ -125,7 +125,7 @@ src_test() {
CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
fi
BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_test
+ cmake_src_test
done
fi
}
@@ -133,7 +133,7 @@ src_test() {
src_install() {
CMAKE_USE_DIR="${S}"
BUILD_DIR="${S}"_build
- cmake-utils_src_install
+ cmake_src_install
if use wireshark-plugins; then
for i in ${plugins}
@@ -144,7 +144,7 @@ src_install() {
CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
fi
BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_install
+ cmake_src_install
done
fi
}