summaryrefslogtreecommitdiff
path: root/net-libs/libbitcoinconsensus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /net-libs/libbitcoinconsensus
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'net-libs/libbitcoinconsensus')
-rw-r--r--net-libs/libbitcoinconsensus/Manifest3
-rw-r--r--net-libs/libbitcoinconsensus/libbitcoinconsensus-0.16.0.ebuild95
2 files changed, 98 insertions, 0 deletions
diff --git a/net-libs/libbitcoinconsensus/Manifest b/net-libs/libbitcoinconsensus/Manifest
index ffc01a961471..1471e8a9d817 100644
--- a/net-libs/libbitcoinconsensus/Manifest
+++ b/net-libs/libbitcoinconsensus/Manifest
@@ -1,4 +1,7 @@
DIST bitcoin-0.15.1.knots20171111.patches.tar.xz 443024 BLAKE2B 5010c8d0f6a0bc8cd22ca7d7c73d9e4e689e369f0ba39b59f62fa6b6af3dcf938dfc87d33d3fe595a6e54d99734277a34af068dc29a6e984c76d529fbbe2f383 SHA512 455fadeac6ad57be111104680ec6939d6bf235eb49cde89b9716d36f6914c255b1b69cdea459d89b1bbca56099e793be0c8d7aacf592a9d78495068297bb5890
+DIST bitcoin-0.16.0.knots20180322.patches.tar.xz 417544 BLAKE2B f14616c81e0694346fd0714032be501ad0b58e82e2a5fcc623b1fdd316759ae7ac584e6c4ab586e8c9f5a402694a36eceac6b2f1c7441da655479f832a8869bd SHA512 9eca9cbae8ce17b38ddb70326760e33e7812db78e79cfe2d1a3518b34eb8fc87fe4c145e46ab60278b14e70a75b3af238342b4e1808a77cbca4b62b8c72fb1eb
DIST bitcoin-v0.15.1.tar.gz 7550228 BLAKE2B 0cbb7d0e9d0e5e8eb33502a28289c3f9c86b7c531ed179f7e3e8b601a69a423fa736238a2caae890fd8850eb505533995e578e676860a4014922fbc238185ebb SHA512 a09b6cb64a1649d11e3fd6deeb13a07b1bf4bed504a2fc1c585919459ca8ac1af8e5ecc89dee487359e831a8f12625d54f408f95bb341033d6380b82c290c0d9
+DIST bitcoin-v0.16.0.tar.gz 6628305 BLAKE2B 69adb5832e2a708431c06bd8ce695f25cfc2b84e7ccf11e77f40c8ec273146208c70a900d0d32f79790cf67fb359c2731b0cecfc1f27ac2d0c4057228a83aed3 SHA512 7a59de44196a3cd5b75bccfe851e8bd7d5a00ae45b6e771e082326d75846e7c6d1f6d449e18b539b95b25aa12b7b79c462367f1c89438bcd1ca6ec84eb42972c
EBUILD libbitcoinconsensus-0.15.1.ebuild 2388 BLAKE2B af9dec58358b370c37b770d6a0762af2940f45aa4f8ba723df2ca8f605dc87672a5134c3c773f5c83103efb4df1e0c9efeb8487a584f37b2063e35510bac0e3a SHA512 fbf7381d56add2aaf0b62016f981efbac71031ecf266a6044f0742d86e30054e01c592e276a0c1e1c66f52f99c642a29fd91757cd39ec9905d85aeb4fe726124
+EBUILD libbitcoinconsensus-0.16.0.ebuild 2344 BLAKE2B 561422a65b6f7a80500cb5422aa116e7c5bbae782ab29c0a392f57abcd14e55669195a6330145e26f2a52558065c46325d825903a93ba35cd6b5af7c4f24f12b SHA512 93d3638e10b6f3200d30b21c9416240b41752da8f50f04968d917b08e268cfce616b764747705526af0cd9a8d7b886f1a970a8b6cc47bc890a59ec18e70c9fca
MISC metadata.xml 679 BLAKE2B 5283fe5aba24ba5d425e68ee4f6b1059378027c116c675d94ffdd44fab28c68ea52434df749a3a906121e2a044e296e8a26975f9653b93e693f3815bddf98d9d SHA512 3a9ccff97c3e952ec4c321184144be64daf4d9a1c03d21cc8aa454162ad1c1d133382cbbf5d21a873ea3bf746ec68c4ed0be0b81e2b562724ca9bd05f481d665
diff --git a/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.16.0.ebuild b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.16.0.ebuild
new file mode 100644
index 000000000000..4fdba1775ec8
--- /dev/null
+++ b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.16.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+BITCOINCORE_COMMITHASH="4b4d7eb255ca8f9a94b92479e6061d129c91a991"
+KNOTS_PV="${PV}.knots20180322"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="Bitcoin Core consensus library"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+ https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~arm ~arm64 ~mips ~ppc ~x86 ~x86-linux"
+IUSE="+asm knots libressl"
+
+DEPEND="
+ >=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/bips.md doc/release-notes.md doc/shared-libraries.md )
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ elog "You are building ${PN} from Bitcoin Knots."
+ elog "For more information, see:"
+ elog "https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+ else
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/2017/11/11/release-${PV}/"
+ fi
+}
+
+src_prepare() {
+ local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+ eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+ if use knots; then
+ eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+ fi
+
+ eapply_user
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ $(use_enable asm)
+ --without-qtdbus
+ --without-libevent
+ --without-qrencode
+ --without-miniupnpc
+ --disable-tests
+ --disable-wallet
+ --disable-zmq
+ --with-libs
+ --disable-util-cli
+ --disable-util-tx
+ --disable-bench
+ --without-daemon
+ --without-gui
+ --disable-ccache
+ --disable-static
+ --with-system-libsecp256k1
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}