summaryrefslogtreecommitdiff
path: root/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild')
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
new file mode 100644
index 000000000000..e7b1dda81e88
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot xdg-utils
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ xdg_environment_reset
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}