summaryrefslogtreecommitdiff
path: root/net-libs/iax/iax-0.2.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /net-libs/iax/iax-0.2.2-r3.ebuild
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'net-libs/iax/iax-0.2.2-r3.ebuild')
-rw-r--r--net-libs/iax/iax-0.2.2-r3.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/net-libs/iax/iax-0.2.2-r3.ebuild b/net-libs/iax/iax-0.2.2-r3.ebuild
index 8f8fb31fe582..42757477e346 100644
--- a/net-libs/iax/iax-0.2.2-r3.ebuild
+++ b/net-libs/iax/iax-0.2.2-r3.ebuild
@@ -1,23 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
-HOMEPAGE="http://www.asterisk.org/"
-SRC_URI="http://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
+HOMEPAGE="https://www.asterisk.org/"
+SRC_URI="https://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug snomhack"
+PATCHES=(
+ "${FILESDIR}/${PV}-debug.patch"
+ "${FILESDIR}/${PV}-memset.patch"
+ "${FILESDIR}/${PV}-sandbox.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PV}-debug.patch"
- epatch "${FILESDIR}/${PV}-memset.patch"
- epatch "${FILESDIR}/${PV}-sandbox.patch"
+ default
eautoreconf
}
@@ -26,8 +30,3 @@ src_configure() {
$(use_enable debug extreme-debug) \
$(use_enable snomhack)
}
-
-src_install () {
- default
- dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
-}