summaryrefslogtreecommitdiff
path: root/net-libs/iax/iax-0.2.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/iax/iax-0.2.2-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/iax/iax-0.2.2-r3.ebuild')
-rw-r--r--net-libs/iax/iax-0.2.2-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/iax/iax-0.2.2-r3.ebuild b/net-libs/iax/iax-0.2.2-r3.ebuild
new file mode 100644
index 000000000000..8f8fb31fe582
--- /dev/null
+++ b/net-libs/iax/iax-0.2.2-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug snomhack"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-debug.patch"
+ epatch "${FILESDIR}/${PV}-memset.patch"
+ epatch "${FILESDIR}/${PV}-sandbox.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug extreme-debug) \
+ $(use_enable snomhack)
+}
+
+src_install () {
+ default
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}