summaryrefslogtreecommitdiff
path: root/net-libs/iax/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/iax/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/iax/files')
-rw-r--r--net-libs/iax/files/0.2.2-debug.patch21
-rw-r--r--net-libs/iax/files/0.2.2-memset.patch12
-rw-r--r--net-libs/iax/files/0.2.2-sandbox.patch19
3 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/iax/files/0.2.2-debug.patch b/net-libs/iax/files/0.2.2-debug.patch
new file mode 100644
index 000000000000..68efdfdd237a
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-debug.patch
@@ -0,0 +1,21 @@
+diff -uNr iax-0.2.2.ORIG/configure.in iax-0.2.2/configure.in
+--- iax-0.2.2.ORIG/configure.in 2014-05-13 13:23:35.083867921 +0100
++++ iax-0.2.2/configure.in 2014-05-13 13:24:25.879870451 +0100
+@@ -25,6 +25,8 @@
+ fi
+
+ if test "$enable_extreme_debug" = yes ; then
++ AC_DEFINE(DEBUG_SUPPORT)
++ AC_DEFINE(DEBUG_DEFAULT)
+ AC_DEFINE(EXTREME_DEBUG)
+ fi
+
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 13:23:35.082867921 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 13:24:32.439870777 +0100
+@@ -1,5 +1,4 @@
+ CFLAGS += -g -Wall -Wstrict-prototypes -I .
+-CFLAGS += -DDEBUG_SUPPORT -DDEBUG_DEFAULT
+ CFLAGS += $(UCFLAGS)
+
+
diff --git a/net-libs/iax/files/0.2.2-memset.patch b/net-libs/iax/files/0.2.2-memset.patch
new file mode 100644
index 000000000000..08408eef98f7
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-memset.patch
@@ -0,0 +1,12 @@
+diff -uNr iax-0.2.2.ORIG/src/md5.c iax-0.2.2/src/md5.c
+--- iax-0.2.2.ORIG/src/md5.c 2014-05-13 13:26:51.570877706 +0100
++++ iax-0.2.2/src/md5.c 2014-05-13 13:27:08.567878553 +0100
+@@ -165,7 +165,7 @@
+ MD5Transform(ctx->buf, (uint32 *) ctx->in);
+ byteReverse((unsigned char *) ctx->buf, 4);
+ memcpy(digest, ctx->buf, 16);
+- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
++ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
+ }
+
+ #ifndef ASM_MD5
diff --git a/net-libs/iax/files/0.2.2-sandbox.patch b/net-libs/iax/files/0.2.2-sandbox.patch
new file mode 100644
index 000000000000..2dc141a73b18
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-sandbox.patch
@@ -0,0 +1,19 @@
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 12:45:58.343755528 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 12:46:30.044757107 +0100
+@@ -9,10 +9,9 @@
+ EXTRA_DIST = md5.h frame.h iax-client.h iax.h
+
+ install:
+- mkdir -p $(includedir)/iax
+- install -m 644 md5.h $(includedir)/iax
+- install -m 644 frame.h $(includedir)/iax
+- install -m 644 iax.h $(includedir)/iax
+- install -m 644 iax-client.h $(includedir)/iax
+- /sbin/ldconfig
++ mkdir -p $(DESTDIR)$(includedir)/iax
++ install -m 644 md5.h $(DESTDIR)$(includedir)/iax
++ install -m 644 frame.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax-client.h $(DESTDIR)$(includedir)/iax
+