summaryrefslogtreecommitdiff
path: root/net-libs/gsnmp/gsnmp-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/gsnmp/gsnmp-0.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/gsnmp/gsnmp-0.3.0.ebuild')
-rw-r--r--net-libs/gsnmp/gsnmp-0.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/gsnmp/gsnmp-0.3.0.ebuild b/net-libs/gsnmp/gsnmp-0.3.0.ebuild
new file mode 100644
index 000000000000..0adc810d0566
--- /dev/null
+++ b/net-libs/gsnmp/gsnmp-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="An SNMP library based on glib and gnet"
+HOMEPAGE="http://cnds.eecs.jacobs-university.de/users/schoenw/articles/software/index.html"
+SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~amd64-linux ~ppc x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/glib:2
+ net-libs/gnet
+"
+RDEPEND="${DEPEND}"
+
+DOCS="README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-g_access.patch \
+ "${FILESDIR}"/${P}-pkg_config.patch \
+ "${FILESDIR}"/${P}-underquoting.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}