summaryrefslogtreecommitdiff
path: root/net-libs/gloox/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-libs/gloox/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-libs/gloox/files')
-rw-r--r--net-libs/gloox/files/gloox-1.0.24-Makefile.patch36
-rw-r--r--net-libs/gloox/files/gloox-1.0.24-musl.patch13
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/gloox/files/gloox-1.0.24-Makefile.patch b/net-libs/gloox/files/gloox-1.0.24-Makefile.patch
new file mode 100644
index 000000000000..40fed6900f0d
--- /dev/null
+++ b/net-libs/gloox/files/gloox-1.0.24-Makefile.patch
@@ -0,0 +1,36 @@
+Call make with the current instance if possible.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -17,12 +17,12 @@ apidox:
+ check: test
+
+ test:
+- make -C src test
++ $(MAKE) -C src test
+
+ leakcheck: leaktest
+
+ leaktest:
+- make -C src leaktest
++ $(MAKE) -C src leaktest
+
+ includetest:
+- make -C src includetest
++ $(MAKE) -C src includetest
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -117,12 +117,12 @@ noinst_HEADERS = config.h prep.h dns.h nonsaslauth.h mucmessagesession.h stanzae
+ EXTRA_DIST = version.rc
+
+ test:
+- make -C tests test
++ $(MAKE) -C tests test
+
+ check: test
+
+ leaktest:
+- make -C tests leaktest
++ $(MAKE) -C tests leaktest
+
+ leakcheck: leaktest
+
diff --git a/net-libs/gloox/files/gloox-1.0.24-musl.patch b/net-libs/gloox/files/gloox-1.0.24-musl.patch
new file mode 100644
index 000000000000..041841ef345e
--- /dev/null
+++ b/net-libs/gloox/files/gloox-1.0.24-musl.patch
@@ -0,0 +1,13 @@
+https://raw.githubusercontent.com/void-linux/void-packages/master/srcpkgs/gloox/patches/gloox-musl.patch
+https://bugs.gentoo.org/713224
+--- a/src/connectiontcpserver.cpp
++++ b/src/connectiontcpserver.cpp
+@@ -51,7 +51,7 @@
+ #endif
+
+ #include <cstdlib>
+-#include <string>
++#include <string.h>
+
+ #ifndef _WIN32_WCE
+ # include <sys/types.h>