summaryrefslogtreecommitdiff
path: root/net-libs/glib-networking/glib-networking-2.50.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /net-libs/glib-networking/glib-networking-2.50.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'net-libs/glib-networking/glib-networking-2.50.0.ebuild')
-rw-r--r--net-libs/glib-networking/glib-networking-2.50.0.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/net-libs/glib-networking/glib-networking-2.50.0.ebuild b/net-libs/glib-networking/glib-networking-2.50.0.ebuild
deleted file mode 100644
index fcf20f749d31..000000000000
--- a/net-libs/glib-networking/glib-networking-2.50.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 multilib-minimal virtualx
-
-DESCRIPTION="Network-related giomodules for glib"
-HOMEPAGE="https://git.gnome.org/browse/glib-networking/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-IUSE="+gnome +libproxy smartcard +ssl test"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-libs/glib-2.46.0:2[${MULTILIB_USEDEP}]
- gnome? ( gnome-base/gsettings-desktop-schemas )
- libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
- smartcard? (
- >=app-crypt/p11-kit-0.18.4[${MULTILIB_USEDEP}]
- >=net-libs/gnutls-3:=[pkcs11,${MULTILIB_USEDEP}] )
- ssl? (
- app-misc/ca-certificates
- >=net-libs/gnutls-3:=[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- >=sys-devel/gettext-0.19.4
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- test? ( sys-apps/dbus[X] )
-"
-# eautoreconf needs >=sys-devel/autoconf-2.65:2.5
-
-src_prepare() {
- default
- # Disable SSLv3 requiring fallback test, which fails with net-libs/gnutls[-sslv3], bug 595952
- # https://bugzilla.gnome.org/show_bug.cgi?id=782853
- sed -i -e '/\/tls\/connection\/fallback\/SSL/d' "${S}"/tls/tests/connection.c || die
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --disable-static \
- --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
- $(use_with gnome gnome-proxy) \
- $(use_with libproxy) \
- $(use_with smartcard pkcs11) \
- $(use_with ssl gnutls)
-}
-
-multilib_src_test() {
- # XXX: non-native tests fail if glib-networking is already installed.
- # have no idea what's wrong. would appreciate some help.
- multilib_is_native_abi || return 0
-
- virtx emake check
-}
-
-multilib_src_install() {
- gnome2_src_install
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- multilib_pkg_postinst() {
- gnome2_giomodule_cache_update \
- || die "Update GIO modules cache failed (for ${ABI})"
- }
- multilib_foreach_abi multilib_pkg_postinst
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
-
- multilib_pkg_postrm() {
- gnome2_giomodule_cache_update \
- || die "Update GIO modules cache failed (for ${ABI})"
- }
- multilib_foreach_abi multilib_pkg_postrm
-}