summaryrefslogtreecommitdiff
path: root/net-libs/dleyna/dleyna-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 19:52:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 19:52:06 +0000
commitd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (patch)
tree48d3c6b3c45f18db0f90650f822ea19a10284f61 /net-libs/dleyna/dleyna-0.8.2.ebuild
parent4161fa7d1be6dac96e36f8ed343f234a8ef3a74f (diff)
gentoo auto-resync : 20:12:2022 - 19:52:06
Diffstat (limited to 'net-libs/dleyna/dleyna-0.8.2.ebuild')
-rw-r--r--net-libs/dleyna/dleyna-0.8.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/dleyna/dleyna-0.8.2.ebuild b/net-libs/dleyna/dleyna-0.8.2.ebuild
new file mode 100644
index 000000000000..7aa0b52432f2
--- /dev/null
+++ b/net-libs/dleyna/dleyna-0.8.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-single-r1
+
+DESCRIPTION="A set of services and D-Bus APIs to simplify access to UPnP/DLNA media devices"
+HOMEPAGE="https://gitlab.gnome.org/World/dLeyna"
+SRC_URI="https://gitlab.gnome.org/World/dLeyna/-/archive/v${PV}/dLeyna-v${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/6" # soname of libdleyna-core-1.0.so
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gssdp-1.6.0:1.6=
+ >=net-libs/gupnp-1.6.0:1.6=
+ >=net-libs/gupnp-av-0.12.9:0=
+ >=media-libs/gupnp-dlna-0.9.4:2.0=
+ >=net-libs/libsoup-3.0:3.0
+ dev-libs/libxml2
+
+ ${PYTHON_DEPS}
+
+ !net-libs/dleyna-connector-dbus
+ !net-libs/dleyna-core
+ !net-libs/dleyna-renderer
+ !net-misc/dleyna-server
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"/dLeyna-v${PV}
+
+src_configure() {
+ local emesonargs=(
+ -Ddbus_service_dir="${EPREFIX}/usr/share/dbus-1/services"
+ -Dman_pages=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}