summaryrefslogtreecommitdiff
path: root/net-libs/czmq/czmq-2.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/czmq/czmq-2.2.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/czmq/czmq-2.2.0-r2.ebuild')
-rw-r--r--net-libs/czmq/czmq-2.2.0-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/czmq/czmq-2.2.0-r2.ebuild b/net-libs/czmq/czmq-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..b3e2ccc2e54e
--- /dev/null
+++ b/net-libs/czmq/czmq-2.2.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION=" High-level C Binding for ZeroMQ"
+HOMEPAGE="http://czmq.zeromq.org"
+SRC_URI="http://download.zeromq.org/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm hppa x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/libsodium:=
+ sys-apps/util-linux
+ >=net-libs/zeromq-2.1
+ <net-libs/zeromq-4
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )"
+
+DOCS=( NEWS AUTHORS )
+
+src_prepare() {
+ sed -i -e 's|-Werror||g' configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+ mv "${ED}"/usr/bin/makecert{,-czmq} || die
+}
+
+pkg_postinst() {
+ elog "Due to file collisions we moved the makecert tool to makecert-${PN}."
+}