summaryrefslogtreecommitdiff
path: root/net-libs/cppzmq/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-libs/cppzmq/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-libs/cppzmq/files')
-rw-r--r--net-libs/cppzmq/files/cppzmq-disable-static.patch35
-rw-r--r--net-libs/cppzmq/files/cppzmq-use-system-catch2.patch27
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/cppzmq/files/cppzmq-disable-static.patch b/net-libs/cppzmq/files/cppzmq-disable-static.patch
new file mode 100644
index 000000000000..12b1c2231205
--- /dev/null
+++ b/net-libs/cppzmq/files/cppzmq-disable-static.patch
@@ -0,0 +1,35 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,7 +20,7 @@
+ message(FATAL_ERROR "ZeroMQ was not found, neither as a CMake package nor via pkg-config")
+ endif()
+
+-if (ZeroMQ_FOUND AND (NOT TARGET libzmq OR NOT TARGET libzmq-static))
++if (ZeroMQ_FOUND AND NOT TARGET libzmq)
+ message(FATAL_ERROR "ZeroMQ version not supported!")
+ endif()
+
+@@ -43,19 +43,20 @@
+ zmq_addon.hpp
+ )
+
+-foreach (target cppzmq cppzmq-static)
++set (cppzmq_targets cppzmq cppzmq-static)
++
++foreach (target ${cppzmq_targets})
+ add_library(${target} INTERFACE)
+ target_include_directories(${target} INTERFACE $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+ $<INSTALL_INTERFACE:include>)
+ endforeach()
+
+ target_link_libraries(cppzmq INTERFACE libzmq)
+-target_link_libraries(cppzmq-static INTERFACE libzmq-static)
+
+ include(GNUInstallDirs)
+ include(CMakePackageConfigHelpers)
+
+-install(TARGETS cppzmq cppzmq-static
++install(TARGETS ${cppzmq_targets}
+ EXPORT ${PROJECT_NAME}-targets)
+
+ install(FILES ${CPPZMQ_HEADERS}
diff --git a/net-libs/cppzmq/files/cppzmq-use-system-catch2.patch b/net-libs/cppzmq/files/cppzmq-use-system-catch2.patch
new file mode 100644
index 000000000000..b15b9172ad43
--- /dev/null
+++ b/net-libs/cppzmq/files/cppzmq-use-system-catch2.patch
@@ -0,0 +1,27 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -9,9 +9,10 @@
+ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/${CMAKE_INSTALL_LIBDIR})
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/${CMAKE_INSTALL_BINDIR})
+
++find_package(Catch2 REQUIRED)
+ include(CTest)
+-include(cmake/catch.cmake)
+-include(${CATCH_MODULE_PATH}/Catch.cmake)
++include(Catch)
++find_path(CATCH_INCLUDE_DIR "catch.hpp" HINT /usr/include/catch/)
+
+ find_package(Threads)
+
+@@ -31,9 +32,9 @@
+ utilities.cpp
+ )
+
+-add_dependencies(unit_tests catch)
++add_dependencies(unit_tests Catch2::Catch2)
+
+-target_include_directories(unit_tests PUBLIC ${CATCH_MODULE_PATH})
++target_include_directories(unit_tests PUBLIC ${CATCH_INCLUDE_DIR})
+ target_link_libraries(
+ unit_tests
+ PRIVATE cppzmq