summaryrefslogtreecommitdiff
path: root/net-libs/adns/adns-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/adns/adns-1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/adns/adns-1.4.ebuild')
-rw-r--r--net-libs/adns/adns-1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/adns/adns-1.4.ebuild b/net-libs/adns/adns-1.4.ebuild
new file mode 100644
index 000000000000..6fcb37315725
--- /dev/null
+++ b/net-libs/adns/adns-1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Advanced, easy to use, asynchronous-capable DNS client library and utilities"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~ian/adns/"
+SRC_URI="ftp://ftp.chiark.greenend.org.uk/users/ian/adns/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ CC=$(tc-getCC) econf || die "econf failed"
+ emake AR=$(tc-getAR) RANLIB=$(tc-getRANLIB) || die "emake failed"
+}
+
+src_install () {
+ dodir /usr/{include,bin,$(get_libdir)}
+ emake prefix="${D}"/usr libdir="${D}"/usr/$(get_libdir) install || die "emake install failed"
+ dodoc README TODO changelog "${FILESDIR}"/README.security
+ dohtml *.html
+ MY_POSTINST_MSG=$(<"${FILESDIR}"/README.security)
+}
+
+pkg_postinst() {
+ ewarn "${MY_POSTINST_MSG}"
+}