summaryrefslogtreecommitdiff
path: root/net-irc/znc/znc-1.7.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /net-irc/znc/znc-1.7.4.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'net-irc/znc/znc-1.7.4.ebuild')
-rw-r--r--net-irc/znc/znc-1.7.4.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-irc/znc/znc-1.7.4.ebuild b/net-irc/znc/znc-1.7.4.ebuild
index 9e33853571da..3bd414de0020 100644
--- a/net-irc/znc/znc-1.7.4.ebuild
+++ b/net-irc/znc/znc-1.7.4.ebuild
@@ -22,7 +22,7 @@ else
https://znc.in/releases/archive/${MY_P}.tar.gz
test? ( ${GTEST_URL} )
"
- KEYWORDS="amd64 ~arm x86"
+ KEYWORDS="amd64 arm x86"
S=${WORKDIR}/${MY_P}
fi
@@ -149,19 +149,19 @@ pkg_postinst() {
readme.gentoo_print_elog
fi
- if [[ -d "${EROOT%/}"/etc/znc ]]; then
- ewarn "${EROOT%/}/etc/znc exists on your system."
+ if [[ -d "${EROOT}"/etc/znc ]]; then
+ ewarn "${EROOT}/etc/znc exists on your system."
ewarn "Due to the nature of the contents of that folder,"
ewarn "we have changed the default configuration to use"
- ewarn " ${EROOT%/}/var/lib/znc"
- ewarn "please move ${EROOT%/}/etc/znc to ${EROOT%/}/var/lib/znc"
+ ewarn " ${EROOT}/var/lib/znc"
+ ewarn "please move ${EROOT}/etc/znc to ${EROOT}/var/lib/znc"
ewarn "or adjust your service configuration."
fi
}
pkg_config() {
- if [[ -e "${EROOT%/}/var/lib/znc" ]]; then
- ewarn "${EROOT%/}/var/lib/znc already exists, aborting to avoid damaging"
+ if [[ -e "${EROOT}/var/lib/znc" ]]; then
+ ewarn "${EROOT}/var/lib/znc already exists, aborting to avoid damaging"
ewarn "any existing configuration. If you are sure you want"
ewarn "to generate a new configuration, remove the folder"
ewarn "and try again."
@@ -169,11 +169,11 @@ pkg_config() {
einfo "Press enter to interactively create a new configuration file for znc."
einfo "To abort, press Control-C"
read
- mkdir -p "${EROOT%/}/var/lib/znc" || die
- chown -R ${PN}:${PN} "${EROOT%/}/var/lib/znc" ||
+ mkdir -p "${EROOT}/var/lib/znc" || die
+ chown -R ${PN}:${PN} "${EROOT}/var/lib/znc" ||
die "Setting permissions failed"
start-stop-daemon --start --user ${PN}:${PN} --env ZNC_NO_LAUNCH_AFTER_MAKECONF=1 \
- "${EROOT%/}"/usr/bin/znc -- --makeconf --datadir "${EROOT%/}/var/lib/znc" ||
+ "${EROOT}"/usr/bin/znc -- --makeconf --datadir "${EROOT}/var/lib/znc" ||
die "Config failed"
einfo
einfo "You can now start the znc service using the init system of your choice."