summaryrefslogtreecommitdiff
path: root/net-irc/znc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 21:18:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 21:18:38 +0000
commitca3d7bcb3126761ac24ef4642964d7e16b1df428 (patch)
treee1e7daaca6abe9ca218985bc106bc2642a03e1ea /net-irc/znc/files
parentc66fa6cf106b825bcc6f1beeff9486ff08232cbe (diff)
gentoo auto-resync : 05:11:2022 - 21:18:38
Diffstat (limited to 'net-irc/znc/files')
-rw-r--r--net-irc/znc/files/znc-1.8.2-fix-swig.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-irc/znc/files/znc-1.8.2-fix-swig.patch b/net-irc/znc/files/znc-1.8.2-fix-swig.patch
new file mode 100644
index 000000000000..d07d136c5940
--- /dev/null
+++ b/net-irc/znc/files/znc-1.8.2-fix-swig.patch
@@ -0,0 +1,43 @@
+From fecdd9895894b3afe903021b0843a422eb4d3308 Mon Sep 17 00:00:00 2001
+From: Alexey Sokolov <alexey+znc@asokolov.org>
+Date: Sat, 5 Nov 2022 12:54:40 +0000
+Subject: [PATCH] Add support SWIG 4.1.0, drop support for < 4.0.1
+
+https://bugs.gentoo.org/878587
+---
+ CMakeLists.txt | 2 +-
+ modules/modperl/CMakeLists.txt | 1 -
+ modules/modpython/CMakeLists.txt | 1 -
+ 3 files changed, 1 insertion(+), 3 deletions(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -173,7 +173,7 @@ if(WANT_PYTHON AND NOT EXISTS
+ endif()
+ endif()
+ if(search_swig)
+- find_package(SWIG 3.0.0)
++ find_package(SWIG 4.0.1)
+ if(NOT SWIG_FOUND)
+ message(FATAL_ERROR
+ "Can't find SWIG, therefore Perl and Python aren't supported. "
+--- a/modules/modperl/CMakeLists.txt
++++ b/modules/modperl/CMakeLists.txt
+@@ -53,7 +53,6 @@ if(SWIG_FOUND)
+ "-I${PROJECT_SOURCE_DIR}/include"
+ "-I${CMAKE_CURRENT_SOURCE_DIR}/.."
+ "-I${CMAKE_CURRENT_SOURCE_DIR}/include"
+- -DZNC_EXPORT_LIB_EXPORT
+ -outdir "${CMAKE_CURRENT_BINARY_DIR}"
+ -o "${CMAKE_CURRENT_BINARY_DIR}/modperl_biglib.cpp"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modperl.i"
+--- a/modules/modpython/CMakeLists.txt
++++ b/modules/modpython/CMakeLists.txt
+@@ -50,7 +50,6 @@ if(SWIG_FOUND)
+ "-I${PROJECT_BINARY_DIR}/include"
+ "-I${PROJECT_SOURCE_DIR}/include"
+ "-I${CMAKE_CURRENT_SOURCE_DIR}/.."
+- -DZNC_EXPORT_LIB_EXPORT
+ -outdir "${CMAKE_CURRENT_BINARY_DIR}"
+ -o "${CMAKE_CURRENT_BINARY_DIR}/modpython_biglib.cpp"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modpython.i"