summaryrefslogtreecommitdiff
path: root/net-irc/weechat/weechat-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-irc/weechat/weechat-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index de9e048a74ce..b33c433ae6d2 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit cmake python-single-r1 xdg-utils
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/weechat/weechat.git"
else
SRC_URI="https://weechat.org/files/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
fi
DESCRIPTION="Portable and multi-interface IRC client"
@@ -27,7 +27,11 @@ PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spe
SCRIPT_LANGS="guile lua +perl php +python ruby tcl"
LANGS=" cs de es fr it ja pl ru"
IUSE="doc man nls test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( nls )
+"
RDEPEND="
dev-libs/libgcrypt:0=
@@ -42,10 +46,11 @@ RDEPEND="
perl? ( dev-lang/perl:= )
php? ( >=dev-lang/php-7.0:*[embed] )
python? ( ${PYTHON_DEPS} )
- ruby? ( || ( dev-lang/ruby:2.6 dev-lang/ruby:2.5 ) )
+ ruby? ( || ( dev-lang/ruby:2.7 dev-lang/ruby:2.6 dev-lang/ruby:2.5 ) )
spell? ( app-text/aspell )
tcl? ( >=dev-lang/tcl-8.4.15:0= )
"
+
DEPEND="${RDEPEND}
test? ( dev-util/cpputest )
"
@@ -59,8 +64,7 @@ BDEPEND="
DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
-# tests need to be fixed to not use system plugins if weechat is already installed
-RESTRICT="test"
+RESTRICT="!test? ( test )"
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -137,6 +141,15 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ if $(locale -a | grep -iq "en_US\.utf.*8"); then
+ cmake_src_test -V
+ else
+ eerror "en_US.UTF-8 locale is required to run ${PN}'s ${FUNCNAME}"
+ die "required locale missing"
+ fi
+}
+
pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update