summaryrefslogtreecommitdiff
path: root/net-irc/weechat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /net-irc/weechat/files
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'net-irc/weechat/files')
-rw-r--r--net-irc/weechat/files/weechat-2.1-tinfo.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/weechat/files/weechat-2.1-tinfo.patch b/net-irc/weechat/files/weechat-2.1-tinfo.patch
new file mode 100644
index 000000000000..e44e06e61f99
--- /dev/null
+++ b/net-irc/weechat/files/weechat-2.1-tinfo.patch
@@ -0,0 +1,28 @@
+Use pkgconfig to find ncurses libs in order to support separate libtinfo.
+
+--- weechat-2.1/src/gui/curses/normal/CMakeLists.txt
++++ weechat-2.1/src/gui/curses/normal/CMakeLists.txt
+@@ -29,7 +29,13 @@
+ ../gui-curses-window.c
+ )
+
+-find_package(Ncurses)
++find_package(PkgConfig)
++pkg_search_module(NCURSES ncursesw ncurses)
++
++if(NOT NCURSES_FOUND)
++ find_package(Ncurses)
++endif(NOT NCURSES_FOUND)
++
+ if(NCURSES_FOUND)
+ check_include_files(ncursesw/ncurses.h NCURSESW_HEADERS)
+ if(NCURSESW_HEADERS)
+@@ -54,7 +60,7 @@
+
+ add_dependencies(${EXECUTABLE} weechat_gui_curses_normal)
+
+-list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY})
++list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY} ${NCURSES_LIBRARIES})
+
+ # Due to circular references, we must link two times with libweechat_core.a and libweechat_gui_common.a
+ target_link_libraries(${EXECUTABLE} ${STATIC_LIBS} weechat_gui_curses_normal ${EXTRA_LIBS} ${STATIC_LIBS})