summaryrefslogtreecommitdiff
path: root/net-irc/rhapsody/rhapsody-0.28b.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /net-irc/rhapsody/rhapsody-0.28b.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'net-irc/rhapsody/rhapsody-0.28b.ebuild')
-rw-r--r--net-irc/rhapsody/rhapsody-0.28b.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/net-irc/rhapsody/rhapsody-0.28b.ebuild b/net-irc/rhapsody/rhapsody-0.28b.ebuild
index 892b4df67e4a..52d276a3bb78 100644
--- a/net-irc/rhapsody/rhapsody-0.28b.ebuild
+++ b/net-irc/rhapsody/rhapsody-0.28b.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="IRC client intended to be displayed on a text console"
HOMEPAGE="http://rhapsody.sourceforge.net/"
@@ -14,25 +14,28 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5.0"
+DEPEND=">=sys-libs/ncurses-5.0:0="
+BDEPEND="virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+PATCHES=(
+ "${FILESDIR}"/${P}-uclibc.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
- epatch "${FILESDIR}"/${P}-uclibc.patch
+src_configure() {
+ PKGCONFIG="$(tc-getPKG_CONFIG)" \
+ ./configure -i /usr/share/rhapsody || die "configure failed"
}
src_compile() {
- ./configure -i /usr/share/rhapsody || die "configure failed"
- emake CC="$(tc-getCC)" LOCALFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" LOCALFLAGS="${CFLAGS}"
}
src_install() {
- dobin rhapsody || die "dobin failed"
+ dobin rhapsody
insinto /usr/share/rhapsody/help
- doins help/*.hlp || die "doins failed"
+ doins help/*.hlp
- dodoc docs/CHANGELOG || die "dodoc failed"
+ dodoc docs/CHANGELOG
}