summaryrefslogtreecommitdiff
path: root/net-irc/quasselgrep/quasselgrep-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/quasselgrep/quasselgrep-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/quasselgrep/quasselgrep-9999.ebuild')
-rw-r--r--net-irc/quasselgrep/quasselgrep-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/quasselgrep/quasselgrep-9999.ebuild b/net-irc/quasselgrep/quasselgrep-9999.ebuild
new file mode 100644
index 000000000000..efe0f9483d65
--- /dev/null
+++ b/net-irc/quasselgrep/quasselgrep-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_COMMIT=502c88bdc7613abb68e868eb520e39ec8a5cf6dd
+
+DESCRIPTION="Tool for searching quassel logs from the commandline"
+HOMEPAGE="https://github.com/fish-face/quasselgrep"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/fish-face/quasselgrep"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fish-face/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+ S="${WORKDIR}/fish-face-${PN}-${MY_COMMIT:0:7}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.5.3[${PYTHON_USEDEP}]"
+
+src_configure() {
+ sed -i 's/pycrypto/pycryptodome/g' "${S}"/setup.py || die "sed failed"
+}