summaryrefslogtreecommitdiff
path: root/net-irc/ngircd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-irc/ngircd/files
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-irc/ngircd/files')
-rw-r--r--net-irc/ngircd/files/ngircd-25-fix-gcc-10.patch77
-rw-r--r--net-irc/ngircd/files/ngircd-25-make-env.patch75
2 files changed, 152 insertions, 0 deletions
diff --git a/net-irc/ngircd/files/ngircd-25-fix-gcc-10.patch b/net-irc/ngircd/files/ngircd-25-fix-gcc-10.patch
new file mode 100644
index 000000000000..33e0d444bd56
--- /dev/null
+++ b/net-irc/ngircd/files/ngircd-25-fix-gcc-10.patch
@@ -0,0 +1,77 @@
+From f27827d7937375b5348107ca7427abf74c9eff3d Mon Sep 17 00:00:00 2001
+From: michi <michi+ngircd@dataswamp.org>
+Date: Tue, 14 Apr 2020 16:53:02 +0200
+Subject: [PATCH] Unbreak GCC 10 (-fno-common) build
+
+---
+ src/ngircd/conn.c | 1 +
+ src/ngircd/conn.h | 14 +++++++++++---
+ src/ngircd/ngircd.c | 1 +
+ src/portab/portab.h | 4 ++++
+ 4 files changed, 17 insertions(+), 3 deletions(-)
+
+diff --git a/src/ngircd/conn.c b/src/ngircd/conn.c
+index f62e9675..e14e6c08 100644
+--- a/src/ngircd/conn.c
++++ b/src/ngircd/conn.c
+@@ -10,6 +10,7 @@
+ */
+
+ #define CONN_MODULE
++#define CONN_MODULE_GLOBAL_INIT
+
+ #include "portab.h"
+
+diff --git a/src/ngircd/conn.h b/src/ngircd/conn.h
+index c642541f..869477f0 100644
+--- a/src/ngircd/conn.h
++++ b/src/ngircd/conn.h
+@@ -105,9 +105,17 @@ typedef struct _Connection
+ #endif
+ } CONNECTION;
+
+-GLOBAL CONNECTION *My_Connections;
+-GLOBAL CONN_ID Pool_Size;
+-GLOBAL long WCounter;
++
++#ifdef CONN_MODULE_GLOBAL_INIT
++CONNECTION *My_Connections;
++CONN_ID Pool_Size;
++long WCounter;
++#else
++extern CONNECTION *My_Connections;
++extern CONN_ID Pool_Size;
++extern long WCounter;
++#endif
++
+
+ #define CONNECTION2ID(x) (long)(x - My_Connections)
+
+diff --git a/src/ngircd/ngircd.c b/src/ngircd/ngircd.c
+index 7166640b..41255ca0 100644
+--- a/src/ngircd/ngircd.c
++++ b/src/ngircd/ngircd.c
+@@ -9,6 +9,7 @@
+ * Please read the file COPYING, README and AUTHORS for more information.
+ */
+
++#define GLOBAL_INIT
+ #include "portab.h"
+
+ /**
+diff --git a/src/portab/portab.h b/src/portab/portab.h
+index 70d5ed3e..43f2f907 100644
+--- a/src/portab/portab.h
++++ b/src/portab/portab.h
+@@ -102,7 +102,11 @@ typedef unsigned char bool;
+ #endif
+
+ #undef GLOBAL
++#ifdef GLOBAL_INIT
+ #define GLOBAL
++#else
++#define GLOBAL extern
++#endif
+
+ /* SPLint */
+
diff --git a/net-irc/ngircd/files/ngircd-25-make-env.patch b/net-irc/ngircd/files/ngircd-25-make-env.patch
new file mode 100644
index 000000000000..e6494c720079
--- /dev/null
+++ b/net-irc/ngircd/files/ngircd-25-make-env.patch
@@ -0,0 +1,75 @@
+--- a/Makefile.am 2016-09-18 18:01:30.000000000 -0000
++++ b/Makefile.am 2020-04-20 14:01:43.166312404 -0000
+@@ -25,13 +25,13 @@
+ rm -f config.log debian
+
+ testsuite:
+- cd src/testsuite && make check
++ cd src/testsuite && ${MAKE} check
+
+ lint:
+- cd src/ngircd && make lint
++ cd src/ngircd && ${MAKE} lint
+
+ srcdoc:
+- cd doc && make srcdoc
++ cd doc && ${MAKE} srcdoc
+
+ have-xcodebuild:
+ @xcodebuild -project contrib/MacOSX/ngIRCd.xcodeproj -list \
+@@ -66,7 +66,7 @@
+ --out ../../$(distdir).mpkg
+ rm -f $(distdir).mpkg.zip
+ zip -ro9 $(distdir).mpkg.zip $(distdir).mpkg
+- make osxpkg-clean
++ ${MAKE} osxpkg-clean
+
+ osxpkg-clean:
+ [ ! -r ngircd.dest ] || sudo -n rm -rf ngircd.dest
+@@ -74,12 +74,12 @@
+
+ osxpkg-dest: have-xcodebuild osxpkg-clean clean
+ ./configure --prefix=/opt/ngircd
+- make xcode
+- make -C contrib/MacOSX de.barton.ngircd.plist
++ ${MAKE} xcode
++ ${MAKE} -C contrib/MacOSX de.barton.ngircd.plist
+ mkdir -p ngircd.dest/opt/ngircd/sbin
+- DESTDIR="$$PWD/ngircd.dest" make -C doc install
+- DESTDIR="$$PWD/ngircd.dest" make -C contrib install
+- DESTDIR="$$PWD/ngircd.dest" make -C man install
++ DESTDIR="$$PWD/ngircd.dest" ${MAKE} -C doc install
++ DESTDIR="$$PWD/ngircd.dest" ${MAKE} -C contrib install
++ DESTDIR="$$PWD/ngircd.dest" ${MAKE} -C man install
+ cp contrib/MacOSX/build/Default/ngIRCd \
+ ngircd.dest/opt/ngircd/sbin/ngircd
+ rm ngircd.dest/opt/ngircd/etc/ngircd.conf
+--- a/doc/Makefile.am 2016-01-16 13:23:40.000000000 -0000
++++ b/doc/Makefile.am 2020-04-20 14:05:45.316912143 -0000
+@@ -55,7 +55,7 @@
+ install-data-hook: $(static_docs) $(toplevel_docs) $(generated_docs)
+ $(MKDIR_P) -m 755 $(DESTDIR)$(sysconfdir)
+ @if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
+- make install-config; \
++ ${MAKE} install-config; \
+ fi
+ $(MKDIR_P) -m 755 $(DESTDIR)$(docdir)
+ for f in $(static_docs) $(toplevel_docs); do \
+@@ -75,7 +75,7 @@
+ uninstall-hook:
+ rm -rf $(DESTDIR)$(docdir)
+ @if cmp --silent sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; then \
+- make uninstall-config; \
++ ${MAKE} uninstall-config; \
+ else \
+ echo; \
+ echo " ** NOTE: Not uninstalling changed configuration file:"; \
+@@ -87,7 +87,7 @@
+ rm -f $(DESTDIR)$(sysconfdir)/ngircd.conf
+
+ srcdoc:
+- make -C src srcdoc
++ ${MAKE} -C src srcdoc
+
+ .PHONY: install-config uninstall-config srcdoc
+