summaryrefslogtreecommitdiff
path: root/net-irc/limnoria/limnoria-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-irc/limnoria/limnoria-99999999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-irc/limnoria/limnoria-99999999.ebuild')
-rw-r--r--net-irc/limnoria/limnoria-99999999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-irc/limnoria/limnoria-99999999.ebuild b/net-irc/limnoria/limnoria-99999999.ebuild
index 0c64a0acb20e..204411eeee8f 100644
--- a/net-irc/limnoria/limnoria-99999999.ebuild
+++ b/net-irc/limnoria/limnoria-99999999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
@@ -43,6 +43,8 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+RESTRICT="!test? ( test )"
+
src_unpack() {
if [[ ${PV} == "99999999" ]]; then
git-r3_src_unpack
@@ -52,7 +54,6 @@ src_unpack() {
}
python_prepare(){
- distutils-r1_python_prepare
if python_is_python3; then
einfo "Removing the RSS plugin because of clashes between libxml2's Python3"
einfo "bindings and feedparser."
@@ -68,13 +69,12 @@ python_install_all() {
python_test() {
pushd "${T}" > /dev/null
PLUGINS_DIR="${BUILD_DIR}/lib/supybot/plugins"
- # recommended by upstream, unknown random failure
- EXCLUDE_PLUGINS=( --exclude="${PLUGINS_DIR}/Scheduler" )
- # recommended by upstream, unknown random failure
- EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Filter" )
+ EXCLUDE_PLUGINS=()
# intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
# runs successfully when running the tests on the installed system
EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Unix" )
+ # Runs despite --no-network (GH #1392)
+ EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Aka" )
"${PYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
--plugins-dir="${PLUGINS_DIR}" --no-network \
--disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \